Unable to continuously stream data for continuous processing

Post your LabVIEW discussions here
Post Reply
rohanp
Newbie
Posts: 0
Joined: Mon Oct 11, 2021 8:15 pm

Unable to continuously stream data for continuous processing

Post by rohanp »

I am using Picoscope 3406D here and trying to understand the stream mode algorithm. I obtained the example files from GitHub

Referring to the PicoScope3000aExampleStreaming.vi, below is my screen capture of front panel of the VI that reflect my settings in use:


As you would notice, the Auto Stop is False.

Then, I expect the code to continuously stream data. To continuously process this data, I am on a lookout for “output array for Channel A”
My understanding is that below shown marking (red arrow) on the block diagram is the appropriate signal line (correct me if I am wrong):


When I run the VI, which remains unaltered as obtained from github, it shows a running plot for channel A as expected.
However, it was found that the outer while loop in which “output array for Channel A” (marked with red arrow) gets defined, only executes once ever (unless apply setting is selected which is irrelevant).


The size of the output array for Channel A remains equal to the set Overview Buffer size.

Then I could only conclude that the inner while loop which sets the Channel A plot running, keeps on showing same data over and over.

Could you help me understand what am I doing wrong here? How to obtain continuous data from channel A for continuous processing? I could achieve my objective if I knew which array is continuously updated as channel A data.

For reference, I have attached the VI as well.
Your help is appreciate in understanding this topic.
Thanks,
Attachments
PicoScope3000aExampleStreaming.vi
(22.16 KiB) Downloaded 140 times
SC2.png
SC1.png

Post Reply