PicoScope 6.13.7 on older OS X 10.11.6 El Capitan

Discussion forum for the new Picoscope Mac software
Post Reply
User avatar
Aclassifier
Newbie
Posts: 0
Joined: Sat Sep 30, 2017 3:11 pm
Location: Trondheim, Norway
Contact:

PicoScope 6.13.7 on older OS X 10.11.6 El Capitan

Post by Aclassifier » Thu Sep 27, 2018 8:59 am

For a particular reason I need to run an older version of OS X. I have now tested PicoScope 6.13.7 and have not found any way to run in in OS X. Summary from [1]:

I am not able to run PicoScope 6.13.7.706 with OS X El Capitan 10.11.6. It crashes with that big error log being sent. It crashes with all three of mono 5.8.0.129 (that was on my machine), downgraded mono 5.0.1.1 and newest mono 5.10.1.57. It also crashes with mono 5.8.1. I only have the Windows 10 on Parallels VM running PicoScope 6.12.9.2917 functional. I have not tested the newer PicoScope for Windows on that platform.

The crashes all show that:

Exception Type: EXC_BAD_ACCESS (SIGABRT)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000042857da
Exception Note: EXC_CORPSE_NOTIFY

This should be a basic pointer error I assume, in PicoScope(?)

[1] http://www.teigfam.net/oyvind/home/tech ... el_capitan disclaimer: no income, no ads, no gifts, just fun and expenses in my blog
Øyvind Teig (Aclassifier)

Hitesh
Site Admin
Site Admin
Posts: 2845
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: PicoScope 6.13.7 on older OS X 10.11.6 El Capitan

Post by Hitesh » Tue Oct 09, 2018 12:46 pm

Hi Øyvind,

For PicoScope 6.13.7 we state the following in the pop-up that appears following a click on the link for the software on our Downloads page:

Note : This release has only been tested on macOS 10.12 Sierra and macOS 10.13 High Sierra.
Its possible that the software might work on El Capitan but it is not something that our Software Test team have done.

Have you tried a Mono Runtime 5.1 version?

Regards,
Hitesh

Technical Support Engineer

Post Reply