Test and Measurement Forum

Problem with pico 3424

Post general discussions on using our drivers to write your own software here

Problem with pico 3424

Postby Guest » Wed Jun 21, 2006 2:51 pm

Hi,
I have picoscope 3424 and I am trying to run my own program using Labview. Sometimes I stopped my program halfway without closing the picoscope. When that happens, the LED continues to lit and I couldnt run the labview using picoscope anymore.

also, I tried plugging the usb but then i plugged the usb back in, the led still lits. I still cant run the labview to run picoscope.
Guest
 

Postby Guest » Wed Jun 21, 2006 3:07 pm

Also, when I try to run with Picoscope software, it says that the picoscope 3424 is not connected.
Guest
 

Postby Michael » Thu Jun 22, 2006 9:02 am

Hello Guest,

YOu wil need to call the Close Unit function to close the driver. If you do not, LabVIEW will hold the driver for ransom unless you close the LV environment and restart.

I have attached a VI with the open and close unit functions set up for you. You will need to use it as a sub VI or simply pull out the bits you need. Either way you will need call the close unit function to stop the driver before stopping the VI.

Best regards,
Michael
Attachments
ps3000 Close.zip
This is the ps3000 Close function VI for LabVIEW 8.0
(4.68 KiB) Downloaded 327 times
Michael - Tech Support
Pico Technology
Web Support Forum
Michael
Zen Master
Zen Master
 
Posts: 656
Joined: Thu Jul 07, 2005 12:41 pm
Location: St Neots, Cambridgeshire

Postby Guest » Thu Jun 22, 2006 1:16 pm

Hi Michael,

Thank you for the help. I am wondering where I can get the attached VI with the open and close unit functions. I'll try it out again and hopefully everything turns out well.

Thanks again
Guest
 

Postby Michael » Fri Jun 23, 2006 9:10 am

Hello,

My apologies, I did not manage to attach the VI.

Please see here now.

Best regards,
Michael
Attachments
ps3000 Close.zip
PS3000 Close Unit VI. YOu can use this as a Sub VI as all you need to pass is the current handle you wish to close.
(4.68 KiB) Downloaded 423 times
Michael - Tech Support
Pico Technology
Web Support Forum
Michael
Zen Master
Zen Master
 
Posts: 656
Joined: Thu Jul 07, 2005 12:41 pm
Location: St Neots, Cambridgeshire

Postby jlamuda » Fri Jun 23, 2006 2:13 pm

Hi, this is Guest. I am still not able to download the attachment file.
It appears in the subject thread that there is an attachment but I am not able to find it in your post. Do I need autorisation to download the attachement? Sorry for the trouble.

Thanks,
Jason
jlamuda
User
User
 
Posts: 2
Joined: Thu Jun 22, 2006 3:47 pm

Postby Michael » Fri Jun 23, 2006 2:19 pm

Another attempt to post the attachement.
Attachments
ps3000 Close.zip
Use this VI as a sub VI. you will only need to pass a valid handle.
(4.68 KiB) Downloaded 337 times
Michael - Tech Support
Pico Technology
Web Support Forum
Michael
Zen Master
Zen Master
 
Posts: 656
Joined: Thu Jul 07, 2005 12:41 pm
Location: St Neots, Cambridgeshire

Postby Michael » Fri Jun 23, 2006 2:19 pm

Another attempt to post the attachement.
Attachments
ps3000 Close.vi
(7.62 KiB) Downloaded 434 times
ps3000 Close.zip
Use this VI as a sub VI. you will only need to pass a valid handle.
(4.68 KiB) Downloaded 322 times
Michael - Tech Support
Pico Technology
Web Support Forum
Michael
Zen Master
Zen Master
 
Posts: 656
Joined: Thu Jul 07, 2005 12:41 pm
Location: St Neots, Cambridgeshire

Postby Guest » Fri Jun 23, 2006 3:03 pm

Hi,

I have received the attachment, however the labview version that I have is 7.1. Is there any way to convert the .vi file so I am able to read the .vi file?

Thanks
Guest
 

Postby Michael » Mon Jun 26, 2006 8:47 am

Hello,

I will resend the file reverted back to LV7.1

Best regards,
Michael
Michael - Tech Support
Pico Technology
Web Support Forum
Michael
Zen Master
Zen Master
 
Posts: 656
Joined: Thu Jul 07, 2005 12:41 pm
Location: St Neots, Cambridgeshire


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests