Test and Measurement Forum

Sample rate with 3406B

Post your LabVIEW discussions here

Sample rate with 3406B

Postby babi » Thu Apr 30, 2015 4:19 pm

Hello everybody,

I have a 3406b and I am trying to use the sample VI coming with software. I notice two strange thing
- When I use PicoScope3000aExampleStreaming.vi , It does not let the sampling interval go less than 20nS any value smaller than 20 make the VI fives an error.
- When I use the PicoScope3000aExampleRapidBlockBulk.vi , It does let the time base goes less than 2 and even setting it to 2 it gives me a 3.5nS sample interval! I attached the screenshot of the vi with a 40 mhz/25nS as input. As you can see also the sampling rate in maximum case is an odd number of 3.56nS !!!

Can somebody please help me to understand :
1- why sampling rate is to odd 3.56nS and how I can set it to a integer ?
2- The 3000 series supposed to have 1nS sampling rate , how can I set to 1nS ?

Thakn you in advance
Babi
Attachments
LV1.png
babi
Newbie
 
Posts: 0
Joined: Thu Apr 30, 2015 3:56 pm

Re: Sample rate with 3406B

Postby Martyn » Tue May 05, 2015 9:50 am

When streaming the sampling interval is limited to 20nS, so that data can be captured and transmitted over the USB without loss. For faster sampling you need to use block modes which capture data to the device and then transmit blocks of data to the PC.

The sampling interval to timebase is calculated by the formula on Page 8 of
https://www.picotech.com/download/manuals/PicoScope3000SeriesAApiProgrammersGuide.pdf
and for 1nS you can only have 1 channel enabled.

Your waveform looks like it is at 25nS per cycle to me.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2280
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests