Test and Measurement Forum

Inconsistent trigger on RS422

Post any questions you may have about our current range of oscilloscopes

Inconsistent trigger on RS422

Postby tonigau » Mon Mar 24, 2014 10:06 am

Picoscope 3224, 100ks/s, 'PicoScope6_r6_7_40' ? ,
Capturing 2 channels of RS422 data TX/RX, 1200,o,8,1 . 11 bytes ~106ms each channel 160ms from start of TX to end of TX, Its on a 1s cycle so plenty of idle time between polls.
With 20ms/div it triggers reliably on the first rising edge of data, But with 50ms/div it often triggers off other rising edges in the data packet. (20ms/div won't capture full RX packet).

Have tried trigger off either channel, Serial decode enabled/disabled, changing samples/sec., numerous advanced triggers, run laptop on battery(unplugged power) but all same result.

Is this a hardware issue with my 3224 ?

I'm trying to capture serial decoded data to correlate with Comm's datalogger & maintenance terminal error logs for analysis.

regards,
tonigau
Newbie
 
Posts: 1
Joined: Wed Jul 01, 2009 8:56 pm
Location: Dot au

Re: Inconsistent trigger on RS422

Postby tonigau » Tue Mar 25, 2014 7:39 am

Was onsite again today where the scope is setup. PS Ver. 6.8.8.16.

Setting the pre-trigger to > 20% (was 1% & 10%) seems to fix the problem, trigger is stable at the first rise, I can capture both complete waveforms now with decoded 422 data.
If only I could real time stamp the start of each decoded packet, that would be useful.
tonigau
Newbie
 
Posts: 1
Joined: Wed Jul 01, 2009 8:56 pm
Location: Dot au

Re: Inconsistent trigger on RS422

Postby Martyn » Mon Mar 31, 2014 8:05 am

Setting the trigger conditions to correctly capture your signal can take a bit of time. Sometimes it is worth using a slow timebase to see the repetitions.

Your request for a real time stamp has been noted.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to USB PC Oscilloscopes

Who is online

Users browsing this forum: No registered users and 0 guests