Test and Measurement Forum

Late Trigger

Post any questions you may have about our current range of oscilloscopes

Late Trigger

Postby cpc333 » Fri Feb 15, 2013 8:45 pm

Hello,

I'm using the the Picoscope software version 6.6.46.1 with a 4227. I'm getting late triggers sometimes. For example in the attached picture, the scope should have triggered at what would be about -.16ms on the graph... for some reason it's triggering late. I there a way to fix this?

Thanks for the help!
-Pat
Attachments
badTrigger.PNG
cpc333
Newbie
 
Posts: 0
Joined: Sat Aug 18, 2012 5:31 pm

Re: Late Trigger

Postby Martyn » Fri Feb 22, 2013 11:34 am

Can you post a copy of the psdata file here or directly to support@picotech.com, it does look rather strange.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Late Trigger

Postby cpc333 » Fri Feb 22, 2013 8:50 pm

I think this is it. Thanks!
Attachments
s32186.psdata
(182.13 KiB) Downloaded 91 times
cpc333
Newbie
 
Posts: 0
Joined: Sat Aug 18, 2012 5:31 pm

Re: Late Trigger

Postby Martyn » Mon Feb 25, 2013 3:16 pm

Can you post the text from Help->About, I need to check the dll version as all the settings seem fine. Alternatively just download the latest version of the software from our website and try with that.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Late Trigger

Postby cpc333 » Mon Feb 25, 2013 6:12 pm

Here is the about page while I'm connected to my scope. :D
Attachments
about2.jpg
cpc333
Newbie
 
Posts: 0
Joined: Sat Aug 18, 2012 5:31 pm

Re: Late Trigger

Postby Martyn » Tue Feb 26, 2013 7:36 am

Can you try dropping the attached dll into the PicoScope 6 folder, C:\Program Files\Pico Technology\PicoScope6, and check if that clears up the issue.
Attachments
ps4000.zip
Newer 4000 driver
(506.56 KiB) Downloaded 84 times
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Late Trigger

Postby cpc333 » Tue Feb 26, 2013 7:11 pm

Thanks I'll give it a try. Why isn't that dll included in the latest Picoscope6 installation? Just curious...
cpc333
Newbie
 
Posts: 0
Joined: Sat Aug 18, 2012 5:31 pm

Re: Late Trigger

Postby Martyn » Tue Feb 26, 2013 7:54 pm

It's part of the new build which has just been produced to support our newly released USB 3.0 scope. So should hit the web shortly.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Late Trigger

Postby cpc333 » Fri Mar 08, 2013 8:09 pm

Here's another strange one (with the latest Picoscope6 download). Not sure how it managed to trigger. It was set to 300mV rising edge on Channel B, but doesn't look like Channel B ever made it to 300mV.
Attachments
test1_version.JPG
test1.psdata
(229.36 KiB) Downloaded 81 times
cpc333
Newbie
 
Posts: 0
Joined: Sat Aug 18, 2012 5:31 pm


Return to USB PC Oscilloscopes

Who is online

Users browsing this forum: No registered users and 1 guest