Picoscope 3423 not seen by new laptop

Forum for discussing PicoScope (version 5)
Post Reply
Posts: 1
Joined: Sun May 29, 2005 9:15 am

Picoscope 3423 not seen by new laptop

Post by iaincs »

Hi, I have recently upgraded my laptop to Dell Vostro 1015 with Windows 7. Tried to use my Picoscope 3423 and opened software - does not see my scope unit! Updated picoscope software to 6.55 and still won't see my scope. Even rebooted m/c with it still attached but nothing - how can I get it working??


Thanks worked a treat :D regards
Last edited by iaincs on Sun May 16, 2010 8:07 am, edited 1 time in total.

Advanced User
Advanced User
Posts: 435
Joined: Thu Jun 07, 2007 10:53 am
Location: Cambridgeshire

Re: Picoscope 3423 not seen by new laptop

Post by PeterF »

The procedure below was written for XP but should be similar for Windows 7.
It sounds as if the loaded driver has been corrupted and it will not be overwritten by a correct driver until it has been un-installed.
Please try this. Plug in the scope and then go to Windows Device Manager.("Control Panel", "System" and then click on the Hardware Tab). If there is an "Unknown USB device" there or a "PicoScope 3000 series" with a yellow warning triangle under USB controllers, left click on it once to highlight and then right click to bring up a list from which select "Uninstall". Once that is done, unplug the scope and then plug it back in again. The Windows "New Hardware Found Wizard" will run. Follow the on-screen instructions and, if the wizard asks to connect to Windows Update, select 'No' and allow Windows to automatically detect and configure your scope after which the scope should show up in device manager again but as a "PicoScope 3000 series Oscilloscope". If you get that, your PicoScope6 software should now work.
If that does not work, please contact us at helpdesk:-

Post Reply