ADC-212 & USB Parallel Port problem

Post any questions about our parallel port products
Post Reply
Posts: 0
Joined: Wed Jul 17, 2013 7:28 am

ADC-212 & USB Parallel Port problem

Post by mikew »

Hi - I'm glad to see that you are still providing support for these older products.
I'm trying to connect the ADC-212 and USB Parallel Port to an older IBM WinXP laptop. The odd thing is that everything worked the first time I tried it yesterday, but since then cannot make it work.
I installed PicoFul_r5_21_2.exe exactly following the instructions I found on your website.
Am following this procedure: Connect ADC-212 and USB PP. Connect 12V adapter to ADC-212 (power light comes on). Plug USB cable between PC and USB PP. Run PicoScope, which is set for ADC-212 and USB-PP1.
Here is what happens: The splash screen appears and I hear the "USB connected" beeps followed a couple of seconds later by the "USB disconnected" beeps. Then the splash screen hangs with an hourglass icon. But... If I unplug the USB cable and plug it in again I get the PicoScope screen. It sort-of works but there are long delays when clicking on menus or drop-down boxes and the triggering is very unpredictable. Then if I quit PicoScope and restart it I usually get an "ADC-212 not found" message.
Other trouble shooting information:
1) I am able to use an ADC-11 (USB) unit using PicoLog with this installation so its seems the install is good.
2) USB PP does appear in the USB section of Device Manager.
3) I have tried 2 different 12VDC power supplies and two USB cables.
4) I tried using a powered USB hub.
5) The PC has a parallel port so I tried using that and got the "ADC-212 not connected" message. However, I don't know if the DB25 cable I found is perhaps defective or the wrong type.
6) As I said above the unit did seem to work correctly the first time I tried it, but not since then.
7) The indicator light on the USB PP behaves oddly. Sometimes it stays on and sometimes is stay off unless I switch to a dfferent USB port. I don't see a pattern to this.
8) The ADC-212 and USB PP were used without problem on a different old laptop (since deceased) a while ago. However I was using the original Pico power supply, which has been lost. I think the original was a a simple linear supply while the new ones I have tried are a 12VDC 1.5A switching supply and a regulated benchtop 12V supply. Is it possible that the original supply was actually greater than 12VDC and that this is required for correct operation?

I would appreciate any thoughts about this. If you think that the Pico components are defective then I need to move on to newer equipment, but am working on a tight budget. Thanks for any help you can provide.
- MW

Site Admin
Site Admin
Posts: 3872
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: ADC-212 & USB Parallel Port problem

Post by Martyn »

The original power supply was 12V 500mA so that shouldn't be the problem. Possibly aged components so I would suggest dropping an email to it may be possible to give it some tlc
Technical Support Manager

Post Reply