PS5242A - Stall at "isReady" Function in Examples

Post your LabVIEW discussions here
Post Reply
Posts: 0
Joined: Fri Dec 18, 2015 3:32 pm

PS5242A - Stall at "isReady" Function in Examples

Post by RMaso »


I'm trying to get started with the PS by attempting to run the example VI's from the SDK. I'm starting with the Rapid Block example as I believe this mode to be best for my application. I noticed when running the VI that it always stalls at the "isReady" call. The return is always zero. I used the default settings for everything else in the VI. The PS itself shows a solid green light, which IIRC, means that it's connected and but not acquiring data. What would cause the stall at "isReady"?

OT: can someone tell me what "mode" the PS6 software uses (stream, block, rapidblock, etc)? I would love to use streaming but I'm trying to acquire a 2.75MHz signal and the limits on streaming at 14-bit resolution of 15.625MS/s is not acceptable. However, using the PS6 software, it appears that it works well enough for my application.

Thanks in advance!

Posts: 279
Joined: Tue Oct 21, 2014 3:07 pm

Re: PS5242A - Stall at "isReady" Function in Examples

Post by AndrewA »


Is the scope waiting for a trigger? The example defaults to have the trigger enabled.

Are you using 32 or 64-bit LabVIEW? If your using 64-bit you need to change the some data types-

-Unsigned 32-bit Integer for PICO STATUS values.
-Signed 64-bit Integers for pointers to callback functions and void pointers (e.g. for the call to ps5000aRunBlock)

See point 9 of topic12601.html

If you are still having issues can you tell me what version of the ps5000a.dll driver you are using.
Open the '' panel for this.

Picoscope 6 - scope modes-

Block mode - High timebase settings

Rapid block - Higher timebase settings, you must use a trigger, set the trigger mode to 'Rapid' (selected models only, on the 5000 series this is 1ms/div and faster)

Streaming - Slow timebase settings, 100ms and slower (default is 200ms) otherwise the scope will use block mode.
You can adjust this transition point in the settings.
To change this; Go to the 'Tools' menu - 'Preferences' - 'Sampling' tab - In the 'collection time' set this to the max. time/division.
For example if you set this to 2s/div the scope still operate in block mode set at timebases of 1s/div or faster

Tip - If you need to use streaming in PicoScope 6 adjust the number of samples to maximum the scope will go (view properties panel) and then use the zoom tools (type in a zoom factor to get sensible scaling)

PS- I tried a 5000 series but only got 9.6MS/s (100ms/divison) in streaming.
Regards Andrew
Technical Specialist

Post Reply