Install error for picoscope/stable,stable 6.14.36-4r5676

Discussion forum for the Picoscope 6 Linux software
Post Reply
tobalur
Newbie
Posts: 0
Joined: Tue Jan 12, 2021 2:45 am

Install error for picoscope/stable,stable 6.14.36-4r5676

Post by tobalur »

Hi, today came the update for picoscope to
picoscope/stable,stable 6.14.36-4r5676 all [upgradable from: 6.14.23-4r580]
This did not work because of an error in libpicoipp_1.3.0-4r78_amd64.deb:

Code: Select all

sudo dpkg -i /var/cache/apt/archives/libpicoipp_1.3.0-4r78_amd64.deb
(Reading database ... 504031 files and directories currently installed.)
Preparing to unpack .../libpicoipp_1.3.0-4r78_amd64.deb ...
dpkg: error processing archive /var/cache/apt/archives/libpicoipp_1.3.0-4r78_amd64.deb (--install):
 conffile name 'etc/ld.so.conf.d/picoscope.conf' is not an absolute pathname
This error can be corrected by removing the first line in DEBIAN/conffiles in the packet libpicoipp which begins with "etc/" (without leading "/") and manually installing the corrected packet with dpkg. After that another "apt update" solves the rest.

Could you please correct the package in your repository?
Hope that helps
TB

brutor
Newbie
Posts: 0
Joined: Tue Jan 12, 2021 9:33 pm

Re: Install error for picoscope/stable,stable 6.14.36-4r5676

Post by brutor »

hi, I have the same problem on a debian/sid system.
Can you explain a little more the solution ?
I'm not used to fiddling with dpkg and debian/conffiles.
Thanks for your help.

ukrcald
Newbie
Posts: 0
Joined: Wed Jan 13, 2021 9:46 am

Re: Install error for picoscope/stable,stable 6.14.36-4r5676

Post by ukrcald »

Same error here on debian testing (bullseye).

Thanks tobalur, good work! Though I have to admit I don't know how to perform the magic you suggest.

I suspect I'm about to google, how to take apart a .deb, edit it and then put it back together again....

R

ja@jaa.org.uk
Newbie
Posts: 0
Joined: Mon Jan 28, 2019 10:30 am

Re: Install error for picoscope/stable,stable 6.14.36-4r5676

Post by ja@jaa.org.uk »

I am having problems with Fedora 33 rpms
Is it the same problem?

[root@harting:~]$ dnf update
Local ja Fedora 33 x86_64 Updates 3.0 MB/s | 3.0 kB 00:00
Dependencies resolved.

Problem 1: package libpicoipp-1.3.0-4r78.x86_64 requires libiomp5.so()(64bit), but none of the providers can be installed
- package libpicoipp-1.3.0-4r78.x86_64 requires libiomp5.so(VERSION)(64bit), but none of the providers can be installed
- cannot install both libpicoipp-1.3.0-4r78.x86_64 and libpicoipp-1.3.0-4r29.x86_64
- cannot install the best update candidate for package libpicoipp-1.3.0-4r29.x86_64
Problem 2: package libpicoipp-1.3.0-4r78.x86_64 requires libiomp5.so()(64bit), but none of the providers can be installed
- package libpicoipp-1.3.0-4r78.x86_64 requires libiomp5.so(VERSION)(64bit), but none of the providers can be installed
- cannot install both libpicoipp-1.3.0-4r78.x86_64 and libpicoipp-1.3.0-4r29.x86_64
- package picoscope-6.14.36-4r5676.noarch requires libpicoipp = 1.3.0-4r78, but none of the providers can be installed
- cannot install the best update candidate for package picoscope-6.14.23-4r580.noarch
Problem 3: package libpicoipp-1.3.0-4r78.x86_64 requires libiomp5.so()(64bit), but none of the providers can be installed
- package libpicoipp-1.3.0-4r78.x86_64 requires libiomp5.so(VERSION)(64bit), but none of the providers can be installed
- cannot install both libpicoipp-1.3.0-4r78.x86_64 and libpicoipp-1.3.0-4r29.x86_64
- package picoscope-6.14.36-4r5676.noarch requires libpicoipp = 1.3.0-4r78, but none of the providers can be installed
- problem with installed package picoscope-6.14.23-4r580.noarch
- package picoscope-6.14.23-4r580.noarch requires libpl1000 = 2.0.40-1r2131, but none of the providers can be installed
- cannot install both libpl1000-2.0.54-1r2438.x86_64 and libpl1000-2.0.40-1r2131.x86_64
- cannot install the best update candidate for package libpl1000-2.0.40-1r2131.x86_64

John

Boremi
Newbie
Posts: 0
Joined: Wed Jul 09, 2014 7:29 am

Re: Install error for picoscope/stable,stable 6.14.36-4r5676

Post by Boremi »

Hello,
I have the same problem on Ubuntu 20.10 in a fresh install on my home computer for teleworking.
The error also comes from libpicoipp_1.3.0-4r78_amd64.deb
Best regards
Remi

ja@jaa.org.uk
Newbie
Posts: 0
Joined: Mon Jan 28, 2019 10:30 am

Re: Install error for picoscope/stable,stable 6.14.36-4r5676

Post by ja@jaa.org.uk »

Background:
I have been using the "Centos" approach on Fedora successfully for over 2 years.
Upgrades have gone smoothly even though the OS is not officially supported

Further Info:
It would seem that libiomp5.so and friends have been removed from libpicoipp and have not appeared elsewhere.
Older version of libpicoipp rpm
[root@harting:~]$ dnf repoquery --provides libpicoipp-1.3.0-4r29.x86_64
Local ja Fedora 33 x86_64 Updates 3.0 MB/s | 3.0 kB 00:00
libiomp5.so()(64bit)
libiomp5.so(GOMP_1.0)(64bit)
libiomp5.so(GOMP_2.0)(64bit)
libiomp5.so(GOMP_3.0)(64bit)
libiomp5.so(GOMP_4.0)(64bit)
libiomp5.so(GOMP_4.5)(64bit)
libiomp5.so(OMP_1.0)(64bit)
libiomp5.so(OMP_2.0)(64bit)
libiomp5.so(OMP_3.0)(64bit)
libiomp5.so(OMP_3.1)(64bit)
libiomp5.so(OMP_4.0)(64bit)
libiomp5.so(OMP_4.5)(64bit)
libiomp5.so(VERSION)(64bit)
libpicoipp = 1.3.0-4r29
libpicoipp(x86-64) = 1.3.0-4r29
libpicoipp.so.1()(64bit)
libpicoipp.so.1(PICOIPP)(64bit)

Newer version
[root@harting:~]$ dnf repoquery --provides libpicoipp-1.3.0-4r78.x86_64
Last metadata expiration check: 0:00:16 ago on Thu 14 Jan 2021 12:36:06 GMT.
libpicoipp = 1.3.0-4r78
libpicoipp(x86-64) = 1.3.0-4r78
libpicoipp.so.1()(64bit)
libpicoipp.so.1(PICOIPP)(64bit)
[root@harting:~]$

Hopefully it is just a matter of waiting until this is fixed.
Any advice in the meantime would be welcome.

John

AndrewA
PICO STAFF
PICO STAFF
Posts: 301
Joined: Tue Oct 21, 2014 3:07 pm

Re: Install error for picoscope/stable,stable 6.14.36-4r5676

Post by AndrewA »

Hi,
I have created a bug for this seems to affecting Debian systems. (amd64 and armhf packages)
I have added rpm packages may also be affected.
For now you can install with the work around for Debian systems, full instructions here-
viewtopic.php?p=145119#p145119
Regards Andrew
Technical Specialist

mprowe
Newbie
Posts: 0
Joined: Sun Jul 06, 2014 7:55 pm

Re: Install error for picoscope/stable,stable 6.14.36-4r5676

Post by mprowe »

I too,are suffering from this problem on SUSE Leap 15.2.

This is the log:

Code: Select all

#### YaST2 conflicts list - generated 2021-02-02 16:19:40 ####
libpicoipp-1.3.0-4r78.x86_64 requires ***libiomp5.so()(64bit)***, but this requirement cannot be provided
deleted providers: libpicoipp-1.3.0-4r29.x86_64
    [ ] do not install libpicoipp-1.3.0-4r78.x86_64
    [ ] break libpicoipp-1.3.0-4r78.x86_64 by ignoring some of its dependencies
picoscope-6.14.36-4r5676.noarch requires libpicoipp = 1.3.0-4r78, but this requirement cannot be provided
not installable providers: libpicoipp-1.3.0-4r78.x86_64[picoscope]
    [ ] do not install picoscope-6.14.36-4r5676.noarch
    [ ] break picoscope-6.14.36-4r5676.noarch by ignoring some of its dependencies
#### YaST2 conflicts list END ###
Just throwing my twopenn'orth into the ring to sat that, yes: RPMs are affected.

Regards,

hcgrant
Newbie
Posts: 0
Joined: Thu Aug 13, 2015 2:56 pm

Re: Install error for picoscope/stable,stable 6.14.36-4r5676

Post by hcgrant »

me too ...
#### YaST2 conflicts list - generated 2021-03-14 10:18:44 ####

picoscope-6.14.36-4r5676.noarch requires libpicoipp = 1.3.0-4r78, but this requirement cannot be provided
not installable providers: libpicoipp-1.3.0-4r78.x86_64[picoscope]
[ ] do not install picoscope-6.14.36-4r5676.noarch

[ ] break picoscope-6.14.36-4r5676.noarch by ignoring some of its dependencies

Post Reply