Raspberry Pi, unable to install picoscope

Discussion forum for the new Picoscope Linux software
Post Reply
evanamelrooij
Newbie
Posts: 0
Joined: Tue Jan 12, 2021 1:18 pm

Raspberry Pi, unable to install picoscope

Post by evanamelrooij »

Hi all,

I installed Ubuntu 20.04 on a raspberry pi 4 which is running smoothly. I know picoscope is supposed to work on the 18.04 version of Ubuntu but for some reason this older release does not want to install on my raspi. I also saw a post from someone installing picoscope6 on ubuntu 20.04 without any problems. However, when I follow the steps from the installation instructions I encounter the first problem at step 3: sudo apt-get update.

Code: Select all

Hit:5 https://labs.picotech.com/debian picoscope InRelease               
Reading package lists... Done                      
N: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository 'https://labs.picotech.com/debian picoscope InRelease' doesn't support architecture 'arm64'
If I ignore this and try to do: sudo apt-get install picoscope, I get an error saying: "E: Unable to locate package picoscope". However, there is a picoscope.list in my sources.list.d like there should be. So I added the architecture option to the picoscope.list entry to

Code: Select all

deb [arch=armhf] https://labs.picotech.com/debian/ picoscope main
to not get the first 'skipping' warning after apt-get update. Then when I try to install picoscope again, it does find the package but still gives me an error afterwards:

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 picoscope : Depends: libpicoipp (= 1.3.0-4r78) but it is not installable
             Depends: libpl1000 (= 2.0.54-1r2438) but it is not installable
             Depends: libps2000 (= 3.0.54-3r2438) but it is not installable
             Depends: libps2000a (= 2.1.54-5r2438) but it is not installable
             Depends: libps3000 (= 4.0.54-3r2438) but it is not installable
             Depends: libps3000a (= 2.1.54-6r2438) but it is not installable
             Depends: libps4000 (= 2.1.54-2r2438) but it is not installable
             Depends: libps4000a (= 2.1.54-2r2438) but it is not installable
             Depends: libps5000 (= 2.1.54-3r2438) but it is not installable
             Depends: libps5000a (= 2.1.54-5r2438) but it is not installable
             Depends: libps6000 (= 2.1.54-6r2438) but it is not installable
             Depends: libps6000a (= 1.0.54-0r2438) but it is not installable
             Depends: libusbdrdaq (= 2.0.54-1r2438) but it is not installable
E: Unable to correct problems, you have held broken packages
Any ideas on how to solve this?

AndrewA
PICO STAFF
PICO STAFF
Posts: 293
Joined: Tue Oct 21, 2014 3:07 pm

Re: Ubuntu on raspi, unable to install picoscope

Post by AndrewA »

Hi,
There is no version of PicoScope 6 for arm based systems (armfh, arm64) which includes the Raspberry Pi family.
Be we do offer armhf drivers under Raspbian OS to write your own applications.
These cannot be installed under Ubuntu on a Raspberry Pi4 which is arm64 architecture.
We do have logging software that will run under Raspbian OS and supports the current range of loggers and most scopes-
https://www.picotech.com/downloads/_lig ... 6-raspbian
Note PicoLog 6 is limited to 1kS/s per channel.

To install armhf drivers (Raspbian OS) see the "Installing drivers only" section here-
https://www.picotech.com/downloads/linux
SDK code examples are available from our GitHub repositories.
https://github.com/picotech
The main code examples are written in- C, C#, VBA Excel, Labview, MATLAB, Python
Regards Andrew
Technical Specialist

Post Reply