Unable to install picoscope on ubuntu mate

Discussion forum for the new Picoscope Linux software
Post Reply
Samrudha
Newbie
Posts: 0
Joined: Wed Sep 11, 2019 7:19 am

Unable to install picoscope on ubuntu mate

Post by Samrudha » Wed Sep 11, 2019 8:21 am

Hello, I have ps2405a and raspberry pi 3 b+ model. I have 2 SD-cards, one loaded with raspbian stretch and other loaded with Ubuntu mate 18.04 armv7.
I have installed drivers using command sudo apt-get install libps2000a and executed example python files from github which is working properly.
However I want to install picoscope on either Mate 18.04 or raspbian stretch, so I followed instructions for installing picoscope on ubuntu 18.04 lts.
After running sudo apt-get install picoscope command, I get this following error on both OS. :-

pi@pi-desktop:~$ sudo apt-get install picoscope
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
picoscope : Depends: picomono (>= 4.6.2.16-1r02) but it is not installable
Depends: libpicoipp (= 1.3.0-4r21) but 1.1.2-4r56 is to be installed
Depends: libpl1000 (= 2.0.0-1r570) but it is not going to be installed
Depends: libps2000 (= 3.0.0-3r570) but it is not going to be installed
Depends: libps2000a (= 2.1.0-5r570) but 2.1.17-5r1443 is to be installed
Depends: libps3000 (= 4.0.0-3r570) but it is not going to be installed
Depends: libps3000a (= 2.1.0-6r570) but it is not going to be installed
Depends: libps4000 (= 2.1.0-2r570) but it is not going to be installed
Depends: libps4000a (= 2.1.0-2r570) but it is not going to be installed
Depends: libps5000 (= 2.1.0-3r570) but it is not going to be installed
Depends: libps5000a (= 2.1.0-5r570) but it is not going to be installed
Depends: libps6000 (= 2.1.0-6r580) but it is not going to be installed
Depends: libusbdrdaq (= 2.0.0-1r570) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
pi@pi-desktop:~$

Can anyone please help me install picoscope install on Mate 18.04 or raspbian stretch .. ?

AndrewA
PICO STAFF
PICO STAFF
Posts: 230
Joined: Tue Oct 21, 2014 3:07 pm

Re: Unable to install picoscope on ubuntu mate

Post by AndrewA » Wed Sep 11, 2019 9:52 am

Hi,

We do not have a version of PicoScope software for the arm platform.
But you can install drivers and library files to write your own software to use our PicoScopes and dataloggers.
See the section "Drivers for Raspberry Pi" at the bottom of https://www.picotech.com/downloads/linux
NOTE we currently only have armhf (32-bit) and not arm64 driver support.
Regards Andrew
Technical Specialist

Samrudha
Newbie
Posts: 0
Joined: Wed Sep 11, 2019 7:19 am

Re: Unable to install picoscope on ubuntu mate

Post by Samrudha » Wed Sep 11, 2019 11:34 am

Hi, but I am running ubuntu 32bit (armv7) on pi .

And on wiki I found that armhf refers to armv7 architecture.
So what ubuntu Mate that I have installed on pi is correct or is there something I am missing..?

Samrudha
Newbie
Posts: 0
Joined: Wed Sep 11, 2019 7:19 am

Re: Unable to install picoscope on ubuntu mate

Post by Samrudha » Wed Sep 11, 2019 1:09 pm

Hi, but I have installed 32bit (armv7) Ubuntu mate on pi 3 b+.
So is it proper or is there something I am missing ... ?

Post Reply