Not all users allowed to load settings

Discussion forum for the new Picoscope Linux software
Post Reply
hklausing
Newbie
Posts: 0
Joined: Fri Aug 09, 2019 7:44 am

Not all users allowed to load settings

Post by hklausing » Mon Aug 12, 2019 11:34 am

If a user tries to load settings an error message occurs (see below).

Technical background:
  • PicoScope 6 Beta v6.13.7.707
  • Hardware Version: 1
  • Driver Version: PS3000A Linux Driver, 2.1.0.570
  • Firmware Version: 1.7.5.0 / 1.0.66.0
  • 3x PicoScope 3406D MSO installed on 3 equal PCs, HP Z640 with RHLE 7.4
  • All accounts have a central home directory, on all PCs they have same conditions
The group pico was assigned to some users, to allow them working with picoscope.

Code: Select all

$ getent group | grep pico
pico:x:983:userng1,userok,userng3,userng4,userng5,userng6,userng7
$ id userok
uid=55721(userok) gid=1000(software) groups=1000(software),983(pico)
$ id userng3
uid=54352(userng3) gid=1000(software) groups=1000(software),983(pico)
The user names are modified for this issue description.

On all PCs user userok is able to store and load setting files that are created with File -> Start-up Settings -> Save Settings As... or with File -> Start-up Settings -> Save User Default Settings.

All other users will get the message: Error while opening file '/home/userng3/.local.kde4/share/Pico Technology/260a68f1-c314-451b-830f-0a5e01d65514/default.PSSETTINGS'.

If I check the directory I get (ls -la):

Code: Select all

drwxrwxr-x 2 userng3 nobody  4096 Aug  8 11:16 .
drwxrwxr-x 3 userng3 nobody  4096 Aug  8 11:14 ..
-rw-rw-r-- 1 userng3 nobody  1102 Aug  8 11:16 PicoScopeAnalytics-MeasurementSessionState
-rw-rw-r-- 1 userng3 nobody  3332 Aug  8 11:15 default.PSSETTINGS
-rw-rw-r-- 1 userng3 nobody 16594 Aug  8 11:16 trace.xml
The directory of userok show this:

Code: Select all

drwxrwxr-x 2 userok nobody  4096 Jul 26 07:56 .
drwxrwxr-x 3 userok nobody  4096 Jul 24 15:33 ..
-rw-rw-r-- 1 userok nobody  1100 Jul 26 07:56 PicoScopeAnalytics-MeasurementSessionState
-rw-rw-r-- 1 userok nobody  3313 Jul 25 16:41 lastsessions.PSSETTINGS
-rw-rw-r-- 1 userok nobody   634 Jul 26 07:56 preferences.xml
-rw-rw-r-- 1 userok nobody 12597 Jul 26 07:56 trace.xml
The menue File -> Save/Save As... creates the same issue as above for all users, except for userok.

The group nobody is created by picoscope the user default group is software.

After closing the Error pop-up window all users can continue working picoscope without any other problems.

How to solve this problem?

Post Reply