CC Generator value update rate for PicoScope 2000 Series

Post any questions you may have about our current range of oscilloscopes
Post Reply
B_Squared
Newbie
Posts: 0
Joined: Tue Jul 11, 2023 9:57 am

CC Generator value update rate for PicoScope 2000 Series

Post by B_Squared »

Hello everyone,
I witnessed a strange behavior using the waveform generator to generate CC signals. When I change the value (let's say from 400mV to 800mV) it updates only when the active channel is triggered AND it finish to fill one screen.
I tested 3 cases :
-channel A active but left unplugged (0V). Trigger set to window mode, threshold set close to 0V, timing set to 1sec/div. A multimeter is plugged to the AWG input. When I change the value of the generator, I clearly see that it update after 10sec or so : the waveform takes 10sec to fill the screen. A trigger event occur right after the screen is filled, and again, if I change the value, I have to wait a complete cycle to see it updated.

-Same as above but timing is now set to 1ms/div. Now when I change the value, it is updated right away (it takes probably 10ms).

-Same as above but threshold is set at 200mV (I don't expect any trigger event) : The value of the generator is never updated.

I wish the generator could update its value without depending on a trigger event on any channel. Is this a normal behavior?

Thank you for your help
Regards

Martyn
Site Admin
Site Admin
Posts: 4538
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: CC Generator value update rate for PicoScope 2000 Series

Post by Martyn »

You can't update the generator value while the scope is armed and waiting for a trigger. You either need to wait for a trigger, or stop and restart the scope.
Martyn
Technical Support Manager

Post Reply