ps2000aCon "Unable to open device" with 2206B

Post your Linux discussions here
Post Reply
meteor
Newbie
Posts: 0
Joined: Tue Feb 04, 2020 12:21 pm

ps2000aCon "Unable to open device" with 2206B

Post by meteor » Tue Feb 04, 2020 1:04 pm

Under Windows 10 the Picoscope software performs well with my 2206B. Since I need access to the device from Linux, I installed the SDK via apt-get. Again, the Picoscope software runs well under Linux.
Then I downloaded the ps2000aCon example code, compiled it via autogen.sh & make.
When running it I get:
PicoScope 2000 Series (A API) Driver Example Program
Version 2.3
Opening the device...
Handle: -1
Unable to open device
Error code : 3

so, the code does not see the 2206B!

I use Linux 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u5 (2019-08-11) x86_64 GNU/Linux.

Any suggestion how to solve the problem?

Post Reply