PicoScope 2204A with LabView

Post your LabVIEW discussions here
Post Reply
PlotBoxRotate
Newbie
Posts: 0
Joined: Fri Mar 20, 2020 9:13 am

PicoScope 2204A with LabView

Post by PlotBoxRotate » Fri Mar 20, 2020 9:20 am

Hi Everyone,

I'm running a PicoScope 2204A with Windows 10. It works great with the PicoScope 6 Software. But I can't seem to get it to work in LabView. I can't even open any of the example .vi's. The error I get is:

LaVIEW: Failed to load dynamic library because of missing external symbols or dependencies, or because of an invalid file format. The file 'PicoScope2000ExampleBlock.vi' could not be loaded.

I am using LabView 2014 Home Edition. 32-bit
I downloaded the 32-bit SDK .exe file and followed the YouTube primer to copy over the .dll driver files.
I've tried both the 2002 and 2002a .vi files from the github. Neither work.
I've also downloaded the shared folder from the github and extracted those files. The ExampleBlock.vi still won't open.

Thanks in advance

AndrewA
PICO STAFF
PICO STAFF
Posts: 262
Joined: Tue Oct 21, 2014 3:07 pm

Re: PicoScope 2204A with LabView

Post by AndrewA » Mon Mar 23, 2020 3:13 pm

Hi,
You no longer need to copy the dll files. If you done this I would delete these copies.
Just install the SDK and download the labview files from the github repository.
Full instructions are here-
https://github.com/picotech/picosdk-ni-labview-examples/blob/master/README.md
32-bit block example is here-
https://github.com/picotech/picosdk-ni-labview-examples/blob/master/ps2000/32-bit-examples/PicoScope2000ExampleBlock.vi
Regards Andrew
Technical Specialist

Post Reply