Test and Measurement Forum

Can't install 6.5.80 on Windows 7

Having problems ? let us know the details here

Can't install 6.5.80 on Windows 7

Postby stivo » Mon Sep 05, 2011 9:48 am

Hi,

I can't install PicoScope6_r6_5_80 on Windows 7 Ultimate SP1 64-bit.

I get an error dialog saying "Error 2902. Operation ixoFileCopy called out of sequence." Here is a snippet of the installer error log:

Code: Select all
Action 2:12:05: WriteRegistryValues. Writing system registry values
WriteRegistryValues: Key: \Software\Microsoft\Windows\CurrentVersion\SideBySide\PatchedComponents, Name: {63E949F6-03BC-5C40-A01F-C8B3B9A1E18E}, Value: C:\Windows\winsxs\x86_policy.8.0.microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_516e2e610f48bda6\\8.0.50727.4053.policy[~]{63E949F6-03BC-5C40-A01F-C8B3B9A1E18E}[~]C:\Windows\winsxs\x86_policy.8.0.microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_516e2e610f48bda6\\8.0.50727.4053.cat[~]{63E949F6-03BC-5C40-A01F-C8B3B9A1E18E}[~]C:\Windows\winsxs\x86_policy.8.0.microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_516e2e610f48bda6\[~]{63E949F6-03BC-5C40-A01F-C8B3B9A1E18E}
WriteRegistryValues: Key: \Software\Microsoft\Windows\CurrentVersion\SideBySide\PatchedComponents, Name: {98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}, Value: C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_d08d7da0442a985d\\msvcr80.dll[~]{98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}[~]C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_d08d7da0442a985d\\msvcp80.dll[~]{98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}[~]C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_d08d7da0442a985d\\x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.4053_x-ww_e6967989.cat[~]{98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}[~]C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_d08d7da0442a985d\\x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.4053_x-ww_e6967989.manifest[~]{98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}[~]C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_d08d7da0442a985d\\msvcm80.dll[~]{98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}[~]C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_none_d08d7da0442a985d\[~]{98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}
Action 2:12:05: WriteEnvironmentStrings. Updating environment strings
WriteEnvironmentStrings: Name: Path, Value: C:\Program Files (x86)\Pico Technology\PicoScope6\, Action 1610612737
Action 2:12:05: RegisterUser. Registering user
RegisterUser: {da9ac8ab-3990-4dbe-820a-3b1f002cd0ae}
Action 2:12:05: RegisterProduct. Registering product
Error 2902.Operation ixoFileCopy called out of sequence.
MSI (s) (1C:F4) [02:12:07:160]: Product: PicoScope 6 -- Error 2902.Operation ixoFileCopy called out of sequence.

Action ended 2:12:07: InstallFinalize. Return value 3.
Action 2:12:07: Rollback. Rolling back action:
Rollback: Registering product
Rollback: Registering user
Rollback: Updating environment strings
Rollback: Writing system registry values
Rollback: Registering program identifiers
Rollback: Registering extension servers
Rollback: Creating shortcuts
Rollback: Copying new files
Rollback: Creating folders
Rollback: Removing ODBC components
Rollback: Updating component registration
Action ended 2:12:13: INSTALL. Return value 3.
Action ended 2:12:13: ExecuteAction. Return value 3.
Action 2:12:13: SetupCompleteError.
Action start 2:12:13: SetupCompleteError.
Info 2826.Control ShowMsiLogText on dialog SetupCompleteError extends beyond the boundaries of the dialog to the right by 24 pixels.
Action 2:12:13: SetupCompleteError. Dialog created
Action 2:12:18: ShowMsiLog.
Action start 2:12:18: ShowMsiLog.
Action ended 2:12:18: ShowMsiLog. Return value 0.
Action ended 2:12:18: SetupCompleteError. Return value 2.
Action ended 2:12:18: INSTALL. Return value 3.
=== Logging stopped: 9/4/2011  2:12:18 ===
MSI (c) (2C:68) [02:12:18:892]: Product: PicoScope 6 -- Installation operation failed.

MSI (c) (2C:68) [02:12:18:892]: Windows Installer installed the product. Product Name: PicoScope 6. Product Version: 6.5.80. Product Language: 1033. Manufacturer: Pico Technology. Installation success or error status: 1603.


What can I do to make this install correctly? Other installations work without a problem and I have installed all MS updates.

Thank you in advance.
stivo
Newbie
 
Posts: 0
Joined: Mon Sep 05, 2011 9:39 am

Re: Can't install 6.5.80 on Windows 7

Postby Hitesh » Mon Sep 05, 2011 2:47 pm

Hi Stivo,

I've tried installing PicoScope R6.5.80.5 on a PC with Windows 7 Ultimate 64-bit and it installed successfully.

I also tried v6.5.84 (Release Candidate) and it installed without any issues.

Have you installed the software using an Administrator account? Please try downloading the software again and reinstalling the application. Alternatively, try v6.5.84 (Release Candidate).

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2063
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Can't install 6.5.80 on Windows 7

Postby stivo » Tue Sep 06, 2011 2:09 am

Hi,

I downloaded v6.5.80 again and tried to install it but still got the same error. I then downloaded v6.5.84 release candidate and it installs ok. Everything seems to work so I will stick with the RC version for now.
stivo
Newbie
 
Posts: 0
Joined: Mon Sep 05, 2011 9:39 am


Return to Getting Started

Who is online

Users browsing this forum: No registered users and 0 guests