Test and Measurement Forum

DrDAQ not pulse counting on digital pin2

Post any questions about our parallel port products

DrDAQ not pulse counting on digital pin2

Postby Robert101 » Wed Aug 31, 2011 2:58 am

Anyone else had trouble pulse counting on digital pin 2 on a DrDAQ?

I have two flow meters configured to connect to the DrDAQ and both work very well for counting the rate of rising edge pulses when wired up to the digital-in/out pin 1 (DI/O#1).

However if I set up DI/O#2 exactly the same way, neither flow meter is read. The signal is definitely getting as far as the input terminal on DI/O#2 and the pin can register when the signal is on or off, just won't count pulse rates.

I've tested it and found:

(DI/O#1)....(Pulse counting works)......(On/Off monitoring works)

(DI/O#2)....(Pulse counting doesn't work).....(On/Off monitoring works)

(DI/O#3 and DI/O#4 don't have the pulse rate measuring option.)

Tests performed:

I've tested on a CRO and both sensors are putting out perfect signals (in any case both are working on DrDAQ's DI/O1).

Using a 1Hz square wave as an input:
> DI/O1 Monitors on/off when set to INPUT. Counts pulse rate when set to rising or falling edge.
> DI/O1 Monitors on/off when set to INPUT. Doesn't register pulses when set to rising or falling edge.


Anyone had a similar issue and might be able to suggest a fix?
Thanks,
Robert
Robert101
Newbie
 
Posts: 0
Joined: Wed Aug 31, 2011 2:51 am

Re: DrDAQ not pulse counting on digital pin2

Postby Martyn » Tue Sep 06, 2011 10:01 am

Can you include the sample code you are using to set up the DI/O

Thanks
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2351
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to Parallel Port Products

Who is online

Users browsing this forum: No registered users and 0 guests