Test and Measurement Forum

TC08 connection

Post any questions about our serial port products

TC08 connection

Postby sandspider » Wed Jul 28, 2004 4:00 am

I use to have a TC08 on an old 486 with windows 95
running. It worked fantastic. During a major upgrade
we lost the serial cable and using now a P3 1Ghz with
windows xp.
Now, Nothing works any more picolog cannot detect
the device on any port. we made severall RS232 cables,
just in case. I'm still getting the error message cannot
find driver v2.5tc08 not connected.
Is there anybody who can help me, I'm about to give
up. :cry:
Posts: 1
Joined: Wed Jul 28, 2004 3:52 am
Location: Australia

Postby markspencer » Wed Jul 28, 2004 8:52 am


I am sorry to hear that you are experiencing problems with your TC-08. The serial cable that you need to use is straght through. ie 1 - 1, 2 - 2,..., 9 - 9.

If you have made your own I would advise checking the conformity to ensure that the pin set up is correct. Once you have done this and confirmed cable is correct, I would advise that you check the voltage available form you serial port. The TC-08 requires a + and - voltage of about 7 volts, if it is not supplied with these voltage then the unit will not work and connection not possible.

Pin 5 - gnd
Pin 4 - -7 volts
Pin 7 - +7 volts

Start Picolog up and then try to connect to the TC-08 through the New Settings configuration routine. Then disconect the serial cable from the TC-08 and test the above pins with a multimeter.

If your PC is not supplying the correct voltage level you have to possible options, power the TC-08 externally, for which I can provide a diagram, or use a USB to Serial Port Adapter.

If you would like to recieve the diagram please send a request to:


requesting the external power supply diagram for serial products.

Best regards,

Mark Spencer
User avatar
Site Admin
Site Admin
Posts: 598
Joined: Wed May 07, 2003 9:45 am

Postby Guest » Wed Mar 02, 2005 1:40 am

Would you please post the diagram showing how to power the TC-08 externally please as I have run into the same problem.

Postby Sarah » Wed Mar 02, 2005 9:37 am


Thank you for your post.

I myself am not able to post the diagram, however will suggest it to those responsible for the website.

In the meantime if you would like to email us at tech@picotech.com then we will be more than happy to email the file to you.

Hope this helps

Best Regards

Return to Serial Port Products

Who is online

Users browsing this forum: No registered users and 0 guests