Test and Measurement Forum

ADC-42 reads -5v on IBM laptop with Windows XP

Forum for discussing PicoScope (version 5)

ADC-42 reads -5v on IBM laptop with Windows XP

Postby guest » Fri Jul 23, 2004 6:03 am

I have an ADC-42 on a dual-boot IBM T21 Laptop (PIII-700 MHz).

The ADC-42 works ok under Windows 98, but not under Windows XP - it just draws a continuous trace of -5vDC.

BIOS LPT Port sttings are:
"Output Only" mode, 378, IRQ7

PicoScope/Help/About.. (under Win98) shows:
Release 5.10.7 - 32 bit
ADC10/12/40/42 Driver V2.8
ADC-42 on LPT1
pico.vxd V1.5
16393 samples/sec

PicoScope/Help/About.. (under WinXP) shows:
Release 5.10.7 - 32 bit
ADC10/12/40/42 Driver V2.8
ADC-42 on LPT1
pico.sys V1.6
20000 samples/sec
guest
 

Postby markspencer » Fri Jul 23, 2004 7:40 am

Hi,

I am sorry to hear that you are experiencing this problem.

When using the ADC-42 on XP check that the pico.sys file is started. This can be checked by doing the following:

Start | All Programs | Accessories | System Tools | System Information

When the window opens select the Software Environment | System Drivers

When this information is displayed in the right side window look for the Pico.sys file, and then under the heading started. It should read 'Yes'

Do you have a printer configured in your XP set up that is not being used in the 98 configuration, or another piece of software that is using the parallel port.

In XP the ports are virtualized you should also try using LPT2, and LPT3.

Best regards,
Regards,

Mark Spencer
User avatar
markspencer
Site Admin
Site Admin
 
Posts: 598
Joined: Wed May 07, 2003 9:45 am

fixed

Postby Guest » Fri Jul 23, 2004 10:46 am

checked PICO.SYS - it is : automatic/started
- PicoScope still not working

also checked for LPT printers & removed
- PicoScope still not working

Changed Device Manager & PicoScope to use LPT2 (& restarted PicoScope)
- PicoScope still not working

Changed Device Manager & PicoScope to use LPT3 (& restarted PicoScope)
- PicoScope still NOW WORKS - Thanks Mark !!
Guest
 

that 5V malfunction on the Picoscope

Postby Joseph » Sun Jul 03, 2005 8:47 pm

I had the same problem with my ThinkPad R40 running on XP. The ADC-42 would function sometimes and not other times. So I installed on a W98SE desktop and got it working about the third try.

Then back to the IBM XP. I tried changing the application and the XP OS to LPT2, then LPT3. No good at all. It showed that the computer could not find the ADC.

And when I changed them both back to LPT1, it still could not find the adc at all. The fix for this is to reinstall the picoscope program.

Now read this: When I had it working "normally", but with that problem that the scope AND the voltmeter sees 5V (most of the time), it made no difference to the performance when I ran picoscope with the adc on the shelf - disconnected from the PC. The program had no problem finding the phantom adc. In fact, now that I fixed everything, it will still operate in phantom mode.

The fix is in the BIOS. Even the bi-directional mode is not good enough for my computer. It needs the ECP mode. Then it works every time. In bi-directional it works some of the time. I cannot find out why.

I got a hint of the fix when I googled the issue and found a similar problem when you try to connect two computers via parallel ports using Symantec Ghost. (I think Norton's original Ghost - the good simple one - was exorcised.) They liked EPP but I used ECP.

Are parallel ports so obsolete that MS does not support them? Am I going to be able to connect anything other than a toaster to the next version of Windows?

As for Pico Tech, you guys need to give warnings about these port incompatibilities. Signals that go from the port to your program need to navigate treacherous seas. So tell us.

Joseph
Joseph
 

Postby Sarah » Tue Jul 05, 2005 8:34 am

Hi

Thank you for your post.

The fix is very often in the mode of the port in the BIOS. Usually the best modes ar:

SPP, Normal, Unidirectional, Output Only.

The ADC-42 is an old product which is now becoming obscelete. All the products that we are releasing now are USB products and thus do not encounter such problems. For those having continuing difficulties with parallel port products we have a USB adaptor which enables you to use them on USB thus overcoming these issues.

Best Regards
Sarah
 

Windows XP and old-school PICO 42

Postby aerosue » Wed Mar 29, 2006 7:36 pm

I had success setting the parallel port to Output Only in the BIOS. I was also using an IBM ThinkPad with Windows XP. The parallel port was set to LPT1.
aerosue
 


Return to PicoScope 5

Who is online

Users browsing this forum: No registered users and 0 guests