Test and Measurement Forum

Version 6.5.78.5 is great

Forum for discussing PicoScope version 6 (non-automotive version)

Version 6.5.78.5 is great

Postby piker » Wed Jul 20, 2011 10:08 pm

Finally a stable version of the Pico software that does everything I need it to.
It doesn't freeze anymore. The Auto Setup works without crashing the program.
When I go away for an hour and come back it's still working. The trace seems smoother
with less less jitter. FINALLY IT SAVES THE GRID FONT SIZE AS PART OF THE SETUP!!!!!!!!!!!
I have been asking for this for 2 years at least. If they never bring out another version I will be
happy and this one will always be saved on my puter in the event it gets buggered in future revs.

Thanks Pico nice job...

BTW I am running XP on a Dell 1520

piker
piker
 

Re: Version 6.5.78.5 is great

Postby alan » Thu Jul 21, 2011 5:19 am

Hi,

I am glad you like the software.

If you do want to try out new features in the future you can now do this whilst keeping the existing release you are happy with. From PicoScope R6.6.2 onwards beta releases install in a different directory and have their own icons / shortcuts.

At the time of writing R6.6.2 Beta is on http://labs.picotech.com/ and offers the following:

1. New keyboard shortcut editor for defining your own shortcuts.
2. New macro recorder for recording frequently–used sequences of operations.
3. Graphing frequency counter for PicoScope 4223, 4224, 4423 and 4424.
4. Recent Files list now shows waveform previews.
5. Upgraded Demo Device (for evaluating the software without a scope).
6. Large file handling and streaming–data storage now more efficient.
7. “Send to back” and “Bring to front” commands for arranging channels.
8. New functions for Math Channels: frequency, derivative, integral, min, max, mean, peak.

Alan
alan
Site Admin
Site Admin
 
Posts: 166
Joined: Thu May 25, 2006 8:02 am

Re: Version 6.5.78.5 is great

Postby Gustav » Sat Jul 23, 2011 11:34 am

Yes, 6.5.78.5 is great.... but

There are still bugs. I use the picoscope 5203 as standalone signal generator, AWG. But the output on the AWG is not enabled before the scope has been making at least one sweep.

This is a strange thing because the AWG output should be enabled (and disabled) in it's own menu, and the scope input should not have any relation to this. After one sweep, the AWG menu works as it should.

This bug is only visible, if the startup file does not make the scope make a first sweep automatically or if the input does not meet trigger condition. The infrequency of the bug makes it so harder to detect. :twisted: And the user will be off gard.


Looking much forward to the keyboard shortcut editor.!! 8) this will be cool.

Also point 6 below, about "large file handling and stream.. etc" is much appreaciated.!
Gustav
Guru
Guru
 
Posts: 63
Joined: Sat Jan 23, 2010 1:33 pm


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 1 guest