Test and Measurement Forum

Stuck in ps2000_get_times_and_values()

Post general discussions on using our drivers to write your own software here

Stuck in ps2000_get_times_and_values()

Postby colindavidfoster » Fri Jan 21, 2011 4:44 pm

Why would an app get stuck in ps2000_get_times_and_values()?

I have taken the ps2000.xls VBA macro example and changed exactly one line of code from
Call ps2000_set_trigger(ps2000_handle, 5, 0, 0, 0, 0)
to
Call ps2000_set_trigger(ps2000_handle, 0, 0, 0, 0, 1)
which, I believe, should enable triggering on CH A with an auto trigger of 1ms. In other words the example should capture some data pretty much immediately no matter whether there is a trigger or not.

However, although the code gets to the ps2000_get_times_and_values() call it never comes out, even if I guarantee a trigger by poking a signal up CH A

To gain control I am forced to disconnect the 2203 from the USB, at which point Excel and VBA come out of their "Not Respondong" state, and reconnect.

There is a thread elsewhere about auto trigger not working in the middle of last year, but the DLL mentioned there is older then the one in the SDK (10.1.0.8) I have downloaded in the last few days. So, unless the bug has slipped back in, this seems to be something different.

Details:
PicoScope 2203
All files taken from PS2000sdk_r10_1_0_8.zip
PS2000.DLL version 2.0.8.44
Windows Vista
Office 2003
colindavidfoster
 

Re: Stuck in ps2000_get_times_and_values()

Postby Chris » Thu Jan 27, 2011 10:32 am

A delay of about 100ms before the ps2000_ready() call should help.
Chris
Site Admin
Site Admin
 
Posts: 169
Joined: Tue Aug 17, 2010 9:00 am
Location: St. Neots


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 1 guest