Test and Measurement Forum

USB PT104 - old problem back?

Post any questions you may have about our current range of USB data loggers

USB PT104 - old problem back?

Postby tisri » Fri Nov 26, 2010 1:34 pm

Many years ago I posted on here about issues with the pt104 drivers for the RS232 Pico unit and problem accessing channel 8 (this is for a dual-input device plugged into socket 4). The problem was eventually resolved, although I found a fix for myself by reverse engineering the DLL.

Now using usbpt104.dll it seems the problem is back. The code that worked fine using the old pt104.dll also works fine using the new library, until I attempt to access channel 8. Then it causes an error so bad it crashes Excel completely.

Am I doing something silly, or has channel 8 been broken again?
tisri
Newbie
 
Posts: 0
Joined: Fri Nov 26, 2010 1:30 pm

Re: USB PT104 - old problem back?

Postby tisri » Fri Nov 26, 2010 3:15 pm

Further to this, if I attempt to read channel 5 it returns error value 16 (invalid channel).

Why does it recognise channel 5 as invalid, yet cause such a serious crash if I attempt to read channel 8?
tisri
Newbie
 
Posts: 0
Joined: Fri Nov 26, 2010 1:30 pm

Re: USB PT104 - old problem back?

Postby Chris » Fri Dec 03, 2010 8:20 pm

This issue has been fixed in the usbtc08.dll, which will be in the sdk download from r10_1_0_9 onwards.
Chris
Site Admin
Site Admin
 
Posts: 169
Joined: Tue Aug 17, 2010 9:00 am
Location: St. Neots


Return to USB PC Data Loggers

Who is online

Users browsing this forum: No registered users and 0 guests