Test and Measurement Forum

TH-03 data fluctuates

Post any questions about our serial port products

TH-03 data fluctuates

Postby Charly » Tue Nov 02, 2010 5:43 pm

I use TH-03 to measure the temp of water as part of a heat pump management system.

I've noticed that sometimes when I restart the system (it generally runs 24hrs a day, 7 days a week) TH-03 can return a different temp from when it was shutdown (seconds before). The body of water is around 51,000 liters and the temp sensor remains in it; so I don't expect its actual temp to vary so quickly.

Sometimes the change is several degrees. The values returned then keep to around this temp (by this I mean that they continue to be around the incorrect value until I restart the system again).

I am using C interface to access TH-03.

Any suggestions on to resolve?
Charly
Newbie
 
Posts: 0
Joined: Tue Nov 02, 2010 5:31 pm

Re: TH-03 data fluctuates

Postby ziko » Mon Nov 08, 2010 4:58 pm

HI,

How are you physically connecting the unit to the PC? Are you using a USB to serial converter or a serial port?

Also howe is the thermistor placed? WHen you say resart the system what exactly are you restatring?

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Re: TH-03 data fluctuates

Postby Charly » Mon Nov 08, 2010 5:56 pm

Hi,

Thanks for getting back to me. To answer your questions in order:

The unit is connected using serial port.

The thermistor is immersed in the water (its mounted in PVC conduit and sealed with waterproof mastic so that just the stainless steel probe is exposed to the water). Its fixed in position.

I reset the unit by powering down the PC and restarting (so a hard reset).

The data fluctuation is a rare event. The system runs 24/7, and I've noticed the problem just a few times over the last year.

Thanks for your help.
Charly
Newbie
 
Posts: 0
Joined: Tue Nov 02, 2010 5:31 pm

Re: TH-03 data fluctuates

Postby ziko » Fri Nov 12, 2010 2:21 pm

So are does the fluctuation happen when start recording after the restart?

Are you using PicoLog recorder or are you writing your own software?
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Re: TH-03 data fluctuates

Postby Charly » Fri Nov 12, 2010 5:27 pm

Hi,

I'm using my own software.
The data drift typically does not happen immediately after a restart, but once the system has been running for a while (days/weeks).

regards
Charly
Charly
Newbie
 
Posts: 0
Joined: Tue Nov 02, 2010 5:31 pm

Re: TH-03 data fluctuates

Postby ziko » Mon Nov 22, 2010 2:54 pm

Hi Charly,

Difficult to say really, I mean have you tried using PicoLog to see if the problem still persists?

If you still are having problems please email support@picotech.com

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots


Return to Serial Port Products

Who is online

Users browsing this forum: No registered users and 0 guests