Test and Measurement Forum

pico 4424 streaming mode

Post your LabVIEW discussions here

pico 4424 streaming mode

Postby marco » Thu Sep 23, 2010 7:23 pm

Hi
I'm trying to use a pico 4000 in streaming mode with the labview example program available in the SDK. Unfortunately it doesn't work. I don't succeed in reading the buffer. I checked the example vi with the SDK manual and the it seems to agree with the procedure described in the manual. Can somebody help me in fixing the problem? I'm using labview

thanks in advance
Marco
marco
Newbie
 
Posts: 0
Joined: Mon Sep 13, 2010 2:20 pm

Re: pico 4424 streaming mode

Postby Chris » Tue Sep 28, 2010 1:21 pm

Hi Marco

Can you tell me what version of LabView you are using?

It works fine in Version 8.5 but we are looking into an issue we found with version 10.0

-Chris.
Chris
Site Admin
Site Admin
 
Posts: 169
Joined: Tue Aug 17, 2010 9:00 am
Location: St. Neots

Re: pico 4424 streaming mode

Postby marco » Tue Sep 28, 2010 2:51 pm

Hi Chris
thanks for your answer
I'm using lv 2009 (32bit). It's installed on windows 7 64 bit with WOW 64. Unfortunately lv 2009 is the only 32 bit version of labview that can be installed on windows7 64 bit, so I cannot downgrade to LV 8.x.


Kind regards

Marco
marco
Newbie
 
Posts: 0
Joined: Mon Sep 13, 2010 2:20 pm

Re: pico 4424 streaming mode

Postby Robin » Thu Sep 30, 2010 8:24 am

Hi Marco

This version should work for you. I have tested it in LabVIEW 2010 and saved it for version 9.

The problem was that the memory addresses of the arrays returned by PicoScope4000StartStreaming.vi changed when the VI returned. This didn't happen in version 8. Moving the terminals outside of the error case structure resolves this problem. However, it causes the addresses to be changed in version 8, meaning that this modification breaks the VI in older versions of LabVIEW!

We will look in to this further, but in the meantime at least this will get you up and running.

Robin
Attachments
PicoScope4000.zip
(76.67 KiB) Downloaded 178 times
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: pico 4424 streaming mode

Postby marco » Thu Sep 30, 2010 11:53 am

Hi Robin
Your new example works!
Thanks a lot
Marco
marco
Newbie
 
Posts: 0
Joined: Mon Sep 13, 2010 2:20 pm


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 1 guest