My PC become very slow when save more than 1000 waveforms

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
rogerhk
Newbie
Posts: 1
Joined: Thu Aug 20, 2009 12:10 pm

My PC become very slow when save more than 1000 waveforms

Post by rogerhk » Tue Jul 20, 2010 4:29 am

Hi,
My system is WinXp Sp3 with 2G memory.
PicoScope 6 version is R6.4.64
Hardware is 5203.

I capture the data every 1 minute and use save the current waveform as to save the data in .mat file (about 25000 samples one file).
I had set the number of waveforms in buffer to 1 already. But after more than 1000 times, the system becomes very slow, and as I open the taskmanger, there is still more than 1G physical memory remains but the system cache becomes more than 1G.

What's the problem?
Does the menory release after I use "save the current waveform as" to save the data in the hard disk?

Best Regards,
Roger

ziko
Advanced User
Advanced User
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Re: My PC become very slow when save more than 1000 waveform

Post by ziko » Wed Jul 21, 2010 1:22 pm

Hi could you send me a settings file please?
Ziko

Technical Specialist

rogerhk
Newbie
Posts: 1
Joined: Thu Aug 20, 2009 12:10 pm

Re: My PC become very slow when save more than 1000 waveform

Post by rogerhk » Thu Jul 22, 2010 10:02 am

hi, where is the setting file?
Thanks for your help

ziko
Advanced User
Advanced User
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Re: My PC become very slow when save more than 1000 waveform

Post by ziko » Thu Jul 22, 2010 12:52 pm

Hi,

You can get the settings file by going into File -> "Saving current Waveform As" and then changing the "Save as type" to be a .pssettings rather than .psdata.

Kind regards
Ziko

Technical Specialist

rogerhk
Newbie
Posts: 1
Joined: Thu Aug 20, 2009 12:10 pm

Re: My PC become very slow when save more than 1000 waveform

Post by rogerhk » Thu Jul 22, 2010 1:30 pm

Pls see the attachment.
Attachments
20100722-4127.pssettings
(2.71 KiB) Downloaded 214 times

ziko
Advanced User
Advanced User
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Re: My PC become very slow when save more than 1000 waveform

Post by ziko » Mon Jul 26, 2010 8:20 am

Hi when you say save one thousand times, are you using the alarm functionality?

There seems to be no trigger selected as well.

Kind regards
Ziko

Technical Specialist

Post Reply