Test and Measurement Forum

TC-08 - Voltage and Temperature

Post any questions you may have about our current range of USB data loggers

TC-08 - Voltage and Temperature

Postby michael3130 » Thu Jun 10, 2010 9:26 am

We currently use TC-08s for temperature measuring. To measure the state of the power supply to the product that we are testing, we attached a thermocouple to the supply cord and we can then, through the temperature generated in the supplly cord, tell roughly when the supply turns on and off. We would like to have a more accurate method of doing this.

Our initial thinking is to break into the supply and reduce the voltage to a small DC voltage and using the single channel terminal board, we should be able to tell when the supply is on and off.

Is it possible to measure temperature and voltage at the same time on the TC-08?
Does Pico supply anything that we can use to reduce the voltage down to the appropiate voltage?
Is there another way to do this?

Thanks

Michael
michael3130
Newbie
 
Posts: 0
Joined: Thu Jun 10, 2010 8:58 am

Re: TC-08 - Voltage and Temperature

Postby olepagh » Thu Jun 10, 2010 3:20 pm

There is no problem in measuring voltage and temperature at the same time (but of course on different channels).

Input is limited to app. 70 mV in voltage mode, so use a simple resistor based voltage divider to reduce your supply voltage to an appropriate voltage less than 70 mV.

Then use a two pair table lookup either direct on input channel calculation or create a calculated parameter.
If your supply is e.g 24.00 V DC and the input channel read e.g. 65,7 mV the table should look like:

raw scaled
0 0
65.7 24000

Scaled parameter = mV

or format Units to Volt:
raw scaled
0 0
65.7 24.0

Use neutral (white) copper-copper mini plugs.
/ Best regards
Ole
Denmark
olepagh
Active User
Active User
 
Posts: 7
Joined: Sat Jan 01, 2005 9:39 am
Location: Copenhagen, Denmark

Re: TC-08 - Voltage and Temperature

Postby michael3130 » Fri Jun 11, 2010 7:30 am

Thanks for your reply Ole.

Michael
michael3130
Newbie
 
Posts: 0
Joined: Thu Jun 10, 2010 8:58 am

Re: TC-08 - Voltage and Temperature

Postby Pico Stuart » Mon Jun 14, 2010 4:26 pm

Hi There,

Thankyou for your posts with regard to measuring voltage on the TC-08.

We do supply a single channel terminal board that has been designed specifically for use with the TC-08.

Introduction

The USB TC-08 Single-Channel Terminal Board is an accessory for the Pico Technology USB TC-08 8-Channel Thermocouple Data Logger. The screw terminals allow wires to be attached to the data logger without soldering and enable the USB TC-08 to measure voltages from 0 to + 5 V or 4-20 mA loop currents. The terminal board is designed for use with the USB TC-08 and is not guaranteed to work with other thermocouple data loggers.

Inputs and switch
Name Function
4-20/5V Input for the positive side of a 4-20 mA loop or 0 to
5 V signal.
500mV Input for the positive side of a 0 to 500 mV signal.
50mV Input for the positive side of a 0 to 50 mV signal.
COM Input for the negative side of any voltage or current
signal.
4-20 mA Set switch to “ON” for a 4-20 mA loop signal.
Set switch to “OFF” for all voltage signals.

Measuring voltages and currents
1) Connect the negative side of your circuit to the COM terminal.
2) Connect the positive side of your circuit to the “5 V”, “500 mV” or “50 mV”
terminal depending on the voltage range of the signal. For a 4-20 mA loop
signal, use the “5 V” input.
3) For a 4-20 mA loop signal, set the switch to “ON”. For a voltage signal, set the
switch to “OFF”.
4) Plug the terminal board into the USB TC-08.
5) Connect the USB TC-08 to the computer using the USB cable supplied with the logger.
6) Run PicoLog on the computer.
7) Go to File -> New Settings.
8) Set the converter type to USB TC-08.
9) Edit one of the USB TC-08 channels and set the “Thermocouple” control to“mV”.
10) PicoLog will display the voltage or current applied to the terminal board in the monitor window.

http://www.picotech.com/thermocouple.html

The voltage displayed in PicoLog corresponds to the input voltage as follows:
Input range PicoLog voltage
0 – 5 V 0 – 50 mV
0 – 500 mV 0 – 50 mV
0 – 50 mV 0 – 50 mV
4 – 20 mA 9.6 – 48 mV

If you require further assistance on this please do not hesitate to contact me via support@picotech.com
Pico Stuart
Site Admin
Site Admin
 
Posts: 72
Joined: Tue Jun 30, 2009 3:08 pm

Re: TC-08 - Voltage and Temperature

Postby staglad » Tue May 17, 2011 9:22 pm

Hi

I have the single channel terminal board with my Pico and have not used it yet as I want to also measure pressure using a transducer that is rated 4-20mA.

However, the reason I have not used it yet is that the supply I want to use for the transducer to work is a 24Vdc power supply to feed the positive side of the transducer. I would then connect the negative connection to the single channel board and then the common on the board to the 0V on the power supply.

My question is, would this work or is the 24Vdc power supply too large and should I be looking at a lower power transducer with a lower voltage rating.

I'm worried about destroying my pico by using a 24Vdc power supply to feed the transducer and that is why I have not tried it yet.

Could you let me know if this is ok please anyone
staglad
 

Re: TC-08 - Voltage and Temperature

Postby PeterF » Thu May 19, 2011 2:15 pm

Hi Michael,
The TC-08 inputs are safe from damage up to +/-30V but will not take correct measurements if the Common Mode voltage applied is greater than about +/-5V on any channel or the differential voltage is greater than 70mV. The "Single Channel Terminal Board", when set to 4-20mA input, puts a resistive load from the input to ground of 240 ohms so the maximum current output of your sensor (20mA) will only develop a maximum of 4.8V across this resistor. There is then a 101:1 attenuator which reduces this voltage down to 47.5mV.
You are quite safe to use your 24V power supply.
Regards,
PeterF.
PeterF
Zen Master
Zen Master
 
Posts: 435
Joined: Thu Jun 07, 2007 10:53 am
Location: Cambridgeshire

RE: TC-08 - Voltage and Temperature

Postby rafabutt » Thu Feb 28, 2013 5:03 pm

Hi everyone,

I'm using the single-Channel Terminal Board for measuring a rms voltage with USB TC-08. The sensor I'm using has a secondary output from 4-20mA. I have checked the output with an ammeter, and it's ok and stable.
However when I use the Terminal with the USB TC-08, the value I measure, 33mV, which is on the possible range (9.6-48mV) is not stable is going down slowly.
Any idea what happens?

Thank you,
rafabutt
Newbie
 
Posts: 0
Joined: Thu Feb 28, 2013 4:21 pm

Re: TC-08 - Voltage and Temperature

Postby PeterF » Fri Mar 01, 2013 8:31 am

Hi,
I have not heard if this before. If you are reading 33mV at the TC-08 you should be getting 3.333V at the input terminals of the terminal board. Could you please monitor this voltage to see if that varies in the same way as the reading on the TC-08. If it does, the TC-08 is simply reading the current correctly and either the sensor is at fault or the DIP-switch on the terminal board is making poor contact when switching-in the 240 ohm load for the 4-20 mA setting. If the later, please contact the helpdesk so that we can exchange the terminal board:-
support@picotech.com
Please contact me again if you have any other questions.
Regards,
PeterF.
PeterF
Zen Master
Zen Master
 
Posts: 435
Joined: Thu Jun 07, 2007 10:53 am
Location: Cambridgeshire

Re: TC-08 - Voltage and Temperature

Postby martin.dahlberg » Mon Dec 01, 2014 4:08 pm

When I try to connect the single channel terminal board I notice two things:

1. Just wiring the GND terminal makes other TC channels go crazy. The GND terminal is connected to a Power supply. I have checked that the supply is connected to same mains outlet as the computer with TC-08. Also tried to connect the supply to a AC-AC transformer for galvanic isolation.

2. The TC-08 does not measure correct - when a volt meter on the pin outs from the terminal board shows 25 mV, the monitor shows 15 mV.

What is the recommendations to make simultaneous measurements of voltage and temperature?
/Martin
martin.dahlberg
Newbie
 
Posts: 0
Joined: Mon Dec 01, 2014 3:13 pm

Re: TC-08 - Voltage and Temperature

Postby Hitesh » Fri Dec 05, 2014 12:44 pm

Hello Martin,

Does the issue occur regardless of which channel the Single Channel Terminal Board is connected to?

Please ensure that the dip switch on the board is set to 'off'.

Which input are you connecting the signal into on the terminal board? Are you measuring the voltage from the power supply and are you using a desktop or laptop PC?

Have you set up any scaling in the PicoLog software?

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2063
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: TC-08 - Voltage and Temperature

Postby martin.dahlberg » Fri Dec 05, 2014 1:48 pm

Thanks for feedback. I have found out that the problem was related to the power supply driving the circuit on which I am measuring the voltage. It was of a switching type, and when I changed to another switching power supply of anothe r type/brand the problem disappeared. Then TC-08 is connected to a stationary PC on the same power outlet as the switching power supply. /Martin
martin.dahlberg
Newbie
 
Posts: 0
Joined: Mon Dec 01, 2014 3:13 pm


Return to USB PC Data Loggers

Who is online

Users browsing this forum: No registered users and 0 guests