Test and Measurement Forum

PicoScope freezing

Forum for discussing PicoScope version 6 (non-automotive version)

PicoScope freezing

Postby glcs » Mon Mar 01, 2010 11:53 pm

I have a Picoscope 4224 running with Windows Vista64 and haven't used the 'scope for a few months (was running with version so have only now upgraded to the latest version , but it's freezing (with "Not responding") as soon as you do anything after it's started up.

Even just clicking Tools/Preferences/OK causes it to freeze. Trying to change any of the settings on the main screen, or starting a capture also cause it to freeze.

Help/About works and it shows that the 4224 has been detected OK.

I completely uninstalled the old version before installing

I've now reverted back to version and it's working OK.

Any ideas on how to get working with Vista64?


Re: PicoScope freezing

Postby PeterF » Wed Mar 17, 2010 11:49 am

This problem in Version R6.3.43 affects a small number of 4000 series scopes and can be fixed by a simple substitution of the file PS4000.dll.
I attach this file inside a "zip" folder. Simply un-zip and then copy the "PS4000.dll" into:-
C:\Program Files\Pico Technology\Picoscope6.
It will overwrite the existing file.
The next issue of PicoScope6 will have the correct file included so you could always wait for the new version and simply upgrade then.
(363.81 KiB) Downloaded 132 times
Zen Master
Zen Master
Posts: 435
Joined: Thu Jun 07, 2007 10:53 am
Location: Cambridgeshire

Re: PicoScope freezing

Postby Guest » Tue Apr 20, 2010 10:04 am

Thanks for the update, good to know this is being addressed.

Apologies for the delay in replying.

Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 1 guest