Test and Measurement Forum

Longterm streaming fails

Post general discussions on using our drivers to write your own software here

Re: Longterm streaming fails

Postby Robin » Wed Jun 02, 2010 9:55 am

Here is the updated driver...
Attachments
PS2000.zip
(346.63 KiB) Downloaded 125 times
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: Longterm streaming fails

Postby andresol » Tue Jun 08, 2010 7:59 am

I found the same streaming problem with my picoscope 4424. Is there an updated driver to fix the bug also for this model?

Thanks a lot
andresol
Newbie
 
Posts: 0
Joined: Wed Apr 07, 2010 2:52 pm

Re: Longterm streaming fails

Postby Robin » Tue Jun 08, 2010 1:51 pm

Hi

We believe we have fixed this problem with the 4000 now as well.

We are currently testing the fix and I will post a new DLL here as soon as it is available.

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: Longterm streaming fails

Postby Robin » Wed Jun 16, 2010 8:37 am

Here is the new driver for the PicoScope 4000 series.
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: Longterm streaming fails

Postby andresol » Thu Jun 17, 2010 7:32 am

First of all, I would like to thank for the support.

I've tested the new ps4000 driver in streaming mode, but again the acquisition of my ps4424 stops at about 33MS, whatever sampling frequency I set.

I'm using labview to control the scope and I probably need also a new ps4000wrap dll, right? Otherwise, I don't know how to fix my problem.

Thanks again
andresol
Newbie
 
Posts: 0
Joined: Wed Apr 07, 2010 2:52 pm

Re: Longterm streaming fails

Postby Robin » Mon Jun 21, 2010 12:18 pm

Hi

Sorry, I posted the wrong version of the driver. You don't need a new version of the wrapper DLL.

This one should be OK.

Let me know how you get on

Robin
Attachments
PS4000.zip
(361.25 KiB) Downloaded 133 times
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: Longterm streaming fails

Postby stefanwiesner » Thu Sep 23, 2010 7:58 am

Hi Robin,

after a long time a got a chance to test your new dll. (version 2.0.8.32). unfortunately it has the same problem as the old one, so it hangs after 70 minutes. can you check if you posted the right dll?

thanks,
Stefan
stefanwiesner
Newbie
 
Posts: 0
Joined: Sat Feb 27, 2010 1:51 pm

Re: Longterm streaming fails

Postby andresol » Mon Apr 18, 2011 1:50 pm

Hi
The driver for 4424 works very well also in streaming mode, now.
Unfortunately, I found the same problem with my new ps4227: it stops after the collection of about 33M samples, whatever sampling frequency I set.

What can I do?

Thanks a lot
Regards
andresol
Newbie
 
Posts: 0
Joined: Wed Apr 07, 2010 2:52 pm

Re: Longterm streaming fails

Postby Chris » Thu Apr 28, 2011 9:25 am

Could you send details of the ps4000.dll driver version you are using to

support@picotech.com
Chris
Site Admin
Site Admin
 
Posts: 169
Joined: Tue Aug 17, 2010 9:00 am
Location: St. Neots

Previous

Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests