Test and Measurement Forum

spectrum averaging

Forum for discussing PicoScope version 6 (non-automotive version)

spectrum averaging

Postby picotech@ussu.us » Mon Jan 25, 2010 4:11 pm

I have recently upgraded to picoscope 6. I find the new software an improvement in some areas and a step backward in others. Unfortunately, I have some problems, specifically in regards to the spectrum view.

I find the new 'averaging' algorithms almost unusable. The 'averaging' takes place of much too long a timescale. In the older software I could use the averaging display more or less in real time to make adjustments to my system. I can no longer do this.

I have read the manual several times. I can find no way to adjust the averaging.

Can you please tell me what I am doing wrong? I found averaging a very useful feature in the past, one which made me use the picoscope over my tek DPO3034 regularly. Now I find the picoscope to be more on par with the DPO and that is a step backward for this user.

Also, it does not seem to me that changing the timebase for the 'scope' display should alter the spectrum display. Every time I change the scope timebase I have to go and re-adjust the spectrum view. This is not a feature... it causes twice as much display manipulation.

Also, changing the number of samples in the FFT should not change the display.

In short, I think your rework of the spectrum display could use some rework... it is much less user friendly than previous implementations.

My best regards. I really love my picoscope. Unfortunately, I find the changes made to the spectrum view a step backwards in ease of use.

AND I FIND THE CONFIRMATION CODE ISSUE NEARLY IMPOSSIBLE TO SATISIFY AND AM REALLY QUITE ANGRY AT THIS POINT. IM A SIMPLE USER AND YOU WANT ME TO SOLVE SOME PUZZLE BEFORE I CAN COMMUNICATE WITH YOU. THIS IS REALLY MADDENING.

sorry
picotech@ussu.us
 

Re: spectrum averaging

Postby Erik » Tue Jan 26, 2010 8:02 am

If you create a forum account and log in there is no confirmation code when you post a message.
It is only there to prove you are human, this is to reduce spam created by automatic scripts.
Erik
PICO STAFF
PICO STAFF
 
Posts: 52
Joined: Mon Oct 23, 2006 8:16 am
Location: Cambridgeshire, UK

Re: spectrum averaging

Postby PeterF » Thu Jan 28, 2010 3:13 pm

Hi,
I think you are actually viewing a "Spectrum Plot" of the current "Scope" view by adding a Spectrum view to an existing Scope view (both on screen at the same time). The Spectrum view is thus locked to the settings of the Scope view and more limited.
Have you tried simply switching from Scope view to Spectrum view only (full screen)? In that case you can adjust the spectrum bandwidth simply and everything else is easier and more responsive. Adjusting the number of "Bins" in Spectrum options will trade-off frequency resolution against update speed.
Please try that first and post again if you still have problems.
Regards,
PeterF.
PeterF
Zen Master
Zen Master
 
Posts: 435
Joined: Thu Jun 07, 2007 10:53 am
Location: Cambridgeshire


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests