Test and Measurement Forum

UART decoding

Forum for discussing PicoScope version 6 (non-automotive version)

Re: UART decoding

Postby adynis » Thu Dec 02, 2010 2:26 pm

The UART decoding concept it's just great !
A confirm the timing problem, in the same time a small hint:
If you set 7 bits data (in place of 8), the decoding of consecutive bytes seems to work (if ignoring the "Framing error" message) :) But we are waiting for the "official" solution.

Best Regards,
Adi
adynis
Active User
Active User
 
Posts: 11
Joined: Sun Mar 22, 2009 2:26 am

Re: UART decoding

Postby elman » Mon Jan 10, 2011 10:00 am

I have tested the new R6.5.51 beta software and now the UART decoding works well!
Thank you Pico team! :D

I have a small suggestion: sometimes it can be useful to see the decoded data as ASCII chars instead of hex binary data. It would be nice to have the possibility to configure the display mode of decoded data from serial decoding as hexadecimal, ASCII or even decimal format.
elman
Newbie
 
Posts: 0
Joined: Mon Dec 14, 2009 10:56 am

Re: UART decoding

Postby elman » Mon Jan 10, 2011 10:09 am

I have a small suggestion: sometimes it can be useful to see the decoded data as ASCII chars instead of hex binary data. It would be nice to have the possibility to configure the display mode of decoded data from serial decoding as hexadecimal, ASCII or even decimal format.


Oops, I see it is already there, only you have to select "In Window" from the "Serial Decoding" options and then from the "View" menu of the "Serial Decoding" window you can select the display format.
So far so good!
Thank you again, nice to see how the sw improves in supporting your nice oscilloscopes.
elman
Newbie
 
Posts: 0
Joined: Mon Dec 14, 2009 10:56 am

Previous

Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests