Test and Measurement Forum

Picoscope 3224 and initialisation of run_streaming_ns toVee

Post general discussions on using our drivers to write your own software here

Picoscope 3224 and initialisation of run_streaming_ns toVee

Postby JimThieser » Mon Nov 16, 2009 3:59 pm

Hi all,
i'm trying to implete the run_streaming_ns function to my Vee programm for a high speed data acquisition but the problem is I don't understand which values I have to give to the run streaming function.
Til now the reply is 0 so there must me a mistake.
Which numbers is necessarr for example for time_unit.
I'm measuring decay of a laserpuls in the range of 200µs.

If anybody has good ideas please let me know.

Cheers Jim
JimThieser
Newbie
 
Posts: 0
Joined: Mon Nov 16, 2009 3:44 pm

Re: Picoscope 3224 and initialisation of run_streaming_ns toVee

Postby Robin » Tue Nov 17, 2009 1:01 pm

Hi Jim

PS3000_TIME_UNITS is an enumerated type with the following values:
PS3000_FS,
PS3000_PS,
PS3000_NS,
PS3000_US,
PS3000_MS,
PS3000_S,

Therefore, if you wish to set you interval in microseconds, you would pass a value of 3 for time_units and if you wanted milliseconds, you would set time_units to 5.

The sample interval is the required interval in units of time_units.

See the user's guide for further details: http://www.picotech.com/document/pdf/ps3000044.pdf

I hope this helps

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests