Test and Measurement Forum

TC-08 USB not recognized

Having problems ? let us know the details here

TC-08 USB not recognized

Postby Guest » Thu Aug 27, 2009 4:25 am

I recently purchased a TC-08 and have been trying to get it to be recognized in windows. I have tried:

-reinstalling and installing the software numerous times without having the device plugged in
-on two different computers XP and Vista x64
-two different usb cables
-attempting to utilize drivers from the sdk
-multiple usb ports on both computers
-selecting pico USB tc-08 under the driver selection that default comes with windows vista (must be dated?)
-different versions of the software

The led does not come on when the device is plugged in, but I assume that is because it is not recognized. When I open the picolog recorder I select tc-08 USB from the drop down, but no devices are listed below.

Any help would be appreciated.
Guest
 

Postby ziko » Thu Aug 27, 2009 11:31 am

Hi and thank you for your post.

After you installed the software, then plug in the device, "Found New Hardware Wizzard" should come up. It should identify the USB TC-08, if the driver has not been installed correctly then you will not be able to identify the product.

Can you check device manager to see if the product appears in there?

You can do this by right clicking on the my computer icon and selecting properties (for vista you can then select Device manager) , then choosing the hardware tab, and then device manager for XP.

Does the device appear under Universal Serial Bus Controllers?

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

tco8 not recognised

Postby Guest » Sun Oct 04, 2009 9:54 am

Mine has the exact same problem as previous poster. In device manager under usb devices its not there and imo not recognised by windows.
Guest
 

Postby ziko » Mon Oct 05, 2009 4:24 pm

Hi if you are having problems with the unit and you have tried the following:

1) Making sure that the USB-TC08 drivers is installed and not the serial TC-08.
2) Tried different USB cables
3) Tried different PC
4) Tried the latest software or at least 5.16.2

Then email us at support@picotech.com to arrange for a repair.

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots


Return to Getting Started

Who is online

Users browsing this forum: No registered users and 0 guests