Test and Measurement Forum

Serial to USB Adapter and ADC-16

Post any questions about our serial port products

Serial to USB Adapter and ADC-16

Postby NickA » Mon Jul 13, 2009 5:50 pm

Hello,
I'm hoping somebody can offer some help.....
We have recently installed a new HP DC7900 SFF PC in one of our Labs. Now this PC doesn't come with a built in serial port so I purchased a usb to serial convertor which I've installed and it works fine. I've tested a serial modem using Hyperterminal and I can query the modem so this tells me the serial port is working fine. Now when we connect an instrument to the ADC-16 which in turn connects to the usb to serial convertor the Picolog software (v5.15.6) reports device status "ADC16 driver version 2.4 ADC16 unit not found" on startup. I have checked under "Converter Preferences" and the correct convertor and com port are set.
To prove the ADC-16 is functioning, I connected it to the old PC (Dell GX280 with onboard serial port) and it works fine so the problem seems to be with the usb to serial convertor although I read on another post on this forum that these convertors should be fine to use.
Does anybody have any suggestions as to what can be done to resolve this issue?

Thanks

Nick
NickA
Active User
Active User
 
Posts: 6
Joined: Mon Jul 13, 2009 5:29 pm
Location: Warrington, Cheshire

Postby ziko » Tue Jul 14, 2009 11:26 am

Hi Nick what com port are you using with USB to serial converter?

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Postby NickA » Tue Jul 14, 2009 11:50 am

ziko wrote:Hi Nick what com port are you using with USB to serial converter?

Kind regards


Hi,
I've tried it using Com1, 3 and 4. None of those ports work although I can talk to the serial modem on either of those ports via Hyperterminal.

Thanks for taking the time to reply :)
NickA
Active User
Active User
 
Posts: 6
Joined: Mon Jul 13, 2009 5:29 pm
Location: Warrington, Cheshire

Postby ziko » Tue Jul 14, 2009 12:37 pm

Hi but what com port does the adapter come under in device manger? Or are you saying you went into device manager and changed the com port number that it was originally assigned?

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Postby NickA » Tue Jul 14, 2009 12:42 pm

ziko wrote:Hi but what com port does the adapter come under in device manger? Or are you saying you went into device manager and changed the com port number that it was originally assigned?

Kind regards


Hi,
Yes, you're correct. I changed the com port via device manager. As I mentioned, for each com port change I tested a connection to a serial modem via Hyperterminal and I could make AT queries to the modem successfully using Com1, 3 and 4 (Com2 is in use by the OS)

Thanks

Nick
NickA
Active User
Active User
 
Posts: 6
Joined: Mon Jul 13, 2009 5:29 pm
Location: Warrington, Cheshire

Postby ziko » Tue Jul 14, 2009 2:21 pm

Hi Ok I would suggest the following, try downloading the latest version of Picolog recorder. Remove the version that you have installed then install the latest one.

I know that some USB to serial converters had some problems due to some kind of chipset that they used and we resolved that on one of our later releases. So if the USB to serial converter you used comes under that chipset it may resolve your problem.

Let me know how you get on.
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Postby NickA » Tue Jul 14, 2009 3:58 pm

Hi Ziko
Ok, I've uninstalled our version of Picolog and then installed firstly 5.20.7 and again I have the same problem with it not recognising the ADC-16. I then uninstalled 5.20.7 and installed 5.16.2 only to have the same problem with that version.
I guess this usb to serial convertor chipset is incompatible with your software or do you have any other suggestions?

I'm open to your suggestions.

Thanks for all your help so far!! :D

Kind Regards

Nick :)
NickA
Active User
Active User
 
Posts: 6
Joined: Mon Jul 13, 2009 5:29 pm
Location: Warrington, Cheshire

Postby ziko » Wed Jul 15, 2009 9:57 am

Hi Nick,

I guess you can try another USB to serial converter the ones we sell we know work:

http://www.picotech.com/usb_data_acquisition.html

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Postby NickA » Wed Jul 15, 2009 10:06 am

Hi Ziko,
Thanks for your help. I've just placed an order now for the cable - Order Ref ECOM007915
Hopefully, this should resolve our problem.

Thanks once again! :)

Nick
NickA
Active User
Active User
 
Posts: 6
Joined: Mon Jul 13, 2009 5:29 pm
Location: Warrington, Cheshire

Postby NickA » Fri Jul 17, 2009 12:52 pm

Hi Ziko,
Just to let you know the usb to serial convertor arrived today. I installed it earlier and now the PC can talk to the instrument as normal!! :D:D
Just FYI, I'm now using software version 5.20.7 and all is fine!

Thanks for all your help :)

Nick
NickA
Active User
Active User
 
Posts: 6
Joined: Mon Jul 13, 2009 5:29 pm
Location: Warrington, Cheshire

Postby ziko » Fri Jul 17, 2009 3:21 pm

Hi NickA,

Thank you for your feedback I'm happy to hear all is good :D.

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots


Return to Serial Port Products

Who is online

Users browsing this forum: No registered users and 0 guests