Test and Measurement Forum

TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.6???

Post your LabVIEW discussions here

TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.6???

Postby frantzse » Mon May 18, 2009 9:39 am

Hi

I've just received the TH-03 Themperature Data Logger and installed the PicoLog software and it seems to work Ok. However I like to used the Labview drivers which seems to be available for only old Labview versions like 4,5,6.
Currently I use the files found in the library TH03.LLB in the software development kit R1.0.0
When I open It in Labview 8.5.1 it says the the files are to Old to be converted. Labview 7.1 manage to open the files but with a broken link in the Call Library Function Node of the th03_channel.vi I fixed this broken link by reconfiguring the link to the th0332.dll by choosing th03_labview under function name.
The vi is now able to run. I’ve connected the TH03 to COM 1. And therefore choose port 1 in the front panels controller. However I get no response from the VI. The ok and the temperature indicator are 0. Is there a newer labview driver available or is there another working fix for these labview files?

Thanks & Regards,
Frantz
frantzse
User
User
 
Posts: 2
Joined: Mon May 18, 2009 9:00 am
Location: Trondheim

Postby Robin » Mon May 18, 2009 12:00 pm

Hi

I just tested and saved these VIs in LabVIEW 8.2.

I hope they're useful.

Robin
Attachments
TH03.zip
(14.38 KiB) Downloaded 221 times
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Postby frantzse » Mon May 18, 2009 2:40 pm

Hi

Your updated Labview driver also work for 8.5.1 and 8.6
Thank you very much

Regards
Frantz
frantzse
User
User
 
Posts: 2
Joined: Mon May 18, 2009 9:00 am
Location: Trondheim

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby luisbgomez » Wed Sep 22, 2010 11:07 am

Hi,

We are planning to buy the TH-03 Thermistor Converter. I downloaded the TH03.llb above and open the example. It gave an error:

Call Library Function Node 'th0332.dll:_th03_labview@20': Library not found or failed.

The library specified for this node cannot be found or cannot be loaded. Right-click the Call Library Function node and select Configure, then choose the correct library name or path.

How can I solve this?

Thanks!
Last edited by luisbgomez on Wed Sep 22, 2010 12:15 pm, edited 1 time in total.
luisbgomez
Newbie
 
Posts: 0
Joined: Wed Sep 22, 2010 10:49 am

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby Robin » Wed Sep 22, 2010 12:01 pm

Hi

All our software can be downloaded from www.picotech.com/software.html

Drivers/examples are included in the siftware development kits (SDKs)

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby luisbgomez » Wed Sep 22, 2010 12:25 pm

Robin wrote:Drivers/examples are included in the siftware development kits (SDKs)

Robin


Thanks Robin,

I downloaded the kit, but include an earlier version I cannot open with LV8.6. I could try to open the llb with an earlier version, I could install on an old computer, but it seems from earlier posts there is an updated version already available.
luisbgomez
Newbie
 
Posts: 0
Joined: Wed Sep 22, 2010 10:49 am

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby Robin » Wed Sep 22, 2010 2:14 pm

Hi

I opened it and re-saved it in version 8.2. You should be able to open it now.

I noticed that you changed your previous post. Regarding the library, make sure that the dll is in the same folder as the llb file. If it still can't find it, double click on the call library function node and select the dll.

Robin
Attachments
TH03.zip
(11.7 KiB) Downloaded 154 times
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby luisbgomez » Wed Sep 22, 2010 2:30 pm

Robin wrote:I noticed that you changed your previous post. Regarding the library, make sure that the dll is in the same folder as the llb file. If it still can't find it, double click on the call library function node and select the dll.

Robin


Yes, I cahnged the previous post after seen in that you have included the zip file.

But still can't find the dll. is it included in the zip file? perhaps I don't have rights to see dll files from from my work computer
luisbgomez
Newbie
 
Posts: 0
Joined: Wed Sep 22, 2010 10:49 am

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby Robin » Wed Sep 22, 2010 2:35 pm

The dll should be in the SDK. It will also be in your PicoLog folder (C:\program files\pico technology\pico full)

I've posted it here too.

Robin
Attachments
th0332.zip
(28.66 KiB) Downloaded 152 times
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby luisbgomez » Wed Sep 22, 2010 3:27 pm

Robin wrote:I've posted it here too.

Robin


Now it loads with no errors. Thanks Robin. the vis are simple. is is true that the temperature can b read efectively every 0.6 sec?
luisbgomez
Newbie
 
Posts: 0
Joined: Wed Sep 22, 2010 10:49 am

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby Robin » Wed Sep 22, 2010 4:26 pm

The conversion time is 2 seconds plus 1 second per active channel:

http://www.picotech.com/thermistor.html

However, you can request values from the driver as frequently as you like. If a new value is not available, the old one will be repeated.
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby CallumHartley » Wed Jun 17, 2015 3:04 pm

Hi I have issues with the same thing, I am currently running labview 14.0 and the drivers from picotech.com are out of date for this version.

Can someone help me either by explaining how to convert these to the correct file or giving me any updated versions?

That would be great.

Thanks in advance, Callum
CallumHartley
Newbie
 
Posts: 0
Joined: Wed Jun 17, 2015 2:58 pm

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby Martyn » Thu Jun 18, 2015 9:19 am

The TH03 is an old product and no longer supported, the previous post on this thread was from 5 years ago.

I would suggest just talking directly to the device over the serial port using LabVIEW serial communication. The protocol is defined on page 14 of the manual
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2280
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby CallumHartley » Thu Jun 18, 2015 10:12 am

Hi Martyn

From following the manual Instructions I still cannot seem to get it working. The issue seems to lie with the version of labview being too new. Having gone through the errors in labview I am at the point where I need to call the library fucntion. I select the th0332.dll and it says "the library selected is not valid for the current platform. For example, you are running 64-bit labview and the library might be 32-bit"

Is there a way around this? Such as an updated dll file. Or is just that the library is too old to communicate with the newer version of labview?

Thanks for your help, Callum
CallumHartley
Newbie
 
Posts: 0
Joined: Wed Jun 17, 2015 2:58 pm

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Postby Martyn » Thu Jun 18, 2015 10:22 am

The driver is too old, the only way to talk to it on a 64bit system would be directly over a serial port, this removes the need for any drivers.

Have you made sure that RTS and DTR lines are in the correct state to power the TH03 ?
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2280
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Next

Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests