Test and Measurement Forum

Pico Scope 2204 and Vee 9.0

Post general discussions on using our drivers to write your own software here

Pico Scope 2204 and Vee 9.0

Postby hitec » Thu May 14, 2009 7:56 am

Hello Forum,

I try go get the 2204 work with the Vee Demo programm.

I switch the Vee 9.0 in 6.0-7.0 execution mode.
The programm starts and the init seems to work. The internal relays click some times.
But if I start the measurement, the function >wait for data< waits forever.

Any ideas?
Is the Windows DLL only for 20xx scopes?

Best regards
Hitec
hitec
Active User
Active User
 
Posts: 5
Joined: Wed May 13, 2009 2:01 pm

Postby Robin » Thu May 14, 2009 8:33 am

Hi

I don't know much about VEE, but ps2000.dll is the correct library for the 2204.

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Postby hitec » Thu May 14, 2009 11:14 am

Hi Robin,

is this DLL tested with Win XP SP3 and Vee 9.0 ?

Robin wrote:Hi

I don't know much about VEE, but ps2000.dll is the correct library for the 2204.

Robin


Best Regards
Hitec
hitec
Active User
Active User
 
Posts: 5
Joined: Wed May 13, 2009 2:01 pm

Postby Robin » Thu May 14, 2009 11:19 am

I'm not sure which version of VEE has been used, but were you able to get the example from the SDK (ps2000.vee) to work?
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Postby hitec » Thu May 14, 2009 1:07 pm

Hi Robin,

I used two version. First the version from PicoScope 5 and then the SDK version.
Both don't work the same way.
See my first post.

Best regards
Hitec
hitec
Active User
Active User
 
Posts: 5
Joined: Wed May 13, 2009 2:01 pm

Postby Robin » Thu May 14, 2009 3:04 pm

Ah, I think I misunderstood your first post. I will have to look in to this.

Has anyone else used the VEE example?
Last edited by Robin on Wed May 20, 2009 11:24 am, edited 1 time in total.
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Something yet in progress? Or dead end with Vee?

Postby hitec » Wed May 20, 2009 9:34 am

Hi Robin,

we choose the pico scope because we need to operate it with Vee.
And your company wrotes: comes with drivers for LabView and Vee.

Please fix it or I have to replace the scope.
We need working Vee drivers.

Best regards
Hitec
hitec
Active User
Active User
 
Posts: 5
Joined: Wed May 13, 2009 2:01 pm

Postby Robin » Thu May 21, 2009 9:09 am

Hi

The drivers do work with VEE and LabVIEW. I think there might have been a problem with that example, however.

I have tested this example with a 2204.

I hope it is useful.

Robin
Attachments
PS2000.zip
(348.35 KiB) Downloaded 287 times
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Now it works!

Postby hitec » Tue May 26, 2009 1:44 pm

Hi robin,

sorry for the delay. I was a little bit busy on other projects.

The problem was the example included in PicoScope 5 and the SDK.
The new one works.

Thanks a lot for the help.

Please change the example in PicoScope 5 and the SDK.

Best regards
Hitec
hitec
Active User
Active User
 
Posts: 5
Joined: Wed May 13, 2009 2:01 pm

Postby Robin » Tue May 26, 2009 4:02 pm

I'm glad it's working. This example will be in the next SDK release.

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Re: Pico Scope 2204 and Vee 9.0

Postby dayvee » Fri Dec 13, 2013 12:26 pm

I am also trying to run some legacy VEE code which runs ok with the 2203 and does not run with the 2204. I tried the new example and its does not work. It fails at the open scope point which returns a zero handle (not ready) Any clues? We are building a bunch new test rigs and planned to integrate the new PICO scope into these and so I gotta get this working please!!
I can get both scopes work ok with picoscope 6, and both start the initialisation process. any clues would be good.
dayvee
Newbie
 
Posts: 0
Joined: Fri Dec 13, 2013 12:22 pm

Re: Pico Scope 2204 and Vee 9.0

Postby Martyn » Fri Dec 13, 2013 2:54 pm

Which 2204 do you have ? The older style, that looks like the 2203, or the new smaller one we have just released ?
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Pico Scope 2204 and Vee 9.0

Postby dayvee » Fri Dec 13, 2013 3:10 pm

I have a new 2204A and I am comparing with the old 2203. I note the new 2204A does not run with the old version old pico-scope either. Would I get better results if i bought a 2204 instead of the 2204A? I have just tried a new installation my lap top in case i had legacy problems and this is the same. I tried PS2000.vee from this thread and the one bundled with the CD that came with the 2204A
dayvee
Newbie
 
Posts: 0
Joined: Fri Dec 13, 2013 12:22 pm

Re: Pico Scope 2204 and Vee 9.0

Postby Martyn » Fri Dec 13, 2013 3:45 pm

Install the latest version of Picoscope 6 software and get the ps2000 DLL from the install directory and try using that.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Pico Scope 2204 and Vee 9.0

Postby dayvee » Fri Dec 13, 2013 3:51 pm

That's what I just did on the lap top and it didn't work. I have tried the same here on a desktop and still returns a zero handle indicating its not ready? I have also tried rebooting the PC's and powering the scope on and off and this seems to have no effect, pico scope 6 is the only thing that works. The old 2203 works with all of this.
dayvee
Newbie
 
Posts: 0
Joined: Fri Dec 13, 2013 12:22 pm

Next

Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests