Test and Measurement Forum

Non-functional VIs after Shared Library Import

Post your LabVIEW discussions here

Non-functional VIs after Shared Library Import

Postby vrpederson » Mon Apr 13, 2009 8:48 pm

After downloading the ps3000sdk_r6_2_2_12.zip file and using LabVIEWs Import Shared Library (.dll) function I end up with two VIs that are "broken", I've attached the VIs in the zip file.

LabVIEW gave me the following error report when the import finished:

Import Shared Library Report

Monday, April 13, 2009 10:40:23 AM



Your generated files are installed in the following folder:
C:\Program Files\National Instruments\LabVIEW 8.5\user.lib\ps3000

Parsing header file warnings:
No errors/warnings occurred when parsing the header file.

The following errors/warnings occurred when generating the wrapper VIs for this shared library.

VI Not Executable
The VI is not executable because of one of the following reasons:
1. The shared library or a dependent file is not installed. To make the VI executable, you must install the shared library and all support files on the computer on which you run the VI.
2. A required custom control might be empty or cannot be found. To make the VI executable, update the custom control manually.
3. The VI contains a parameter with an unsupported data type. To make the VI executable, you must replace the empty cluster that the wizard generates with a control or indicator that uses supported data types.
get streaming last values.vi
save streaming data.vi


What exactly do I need to do to fix these non-functioning VIs?

Thanks
Attachments
VIs.zip
(15.92 KiB) Downloaded 163 times
vrpederson
User
User
 
Posts: 3
Joined: Mon Apr 13, 2009 8:34 pm
Location: Washington

Postby Robin » Tue Apr 14, 2009 8:47 am

Hi

Can you save them for Labview 8.2? I will have a look.

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Postby vrpederson » Tue Apr 14, 2009 3:56 pm

Robin,
Thanks for the quick response. Here is a zip of the LabVIEW library with the VIs converted to LabVIEW 8.2. I couldn't include all of the LabVIEW VIs created because of the attachment size limitation.

Thanks,
Verne
Attachments
ps3000.zip
(18.2 KiB) Downloaded 153 times
vrpederson
User
User
 
Posts: 3
Joined: Mon Apr 13, 2009 8:34 pm
Location: Washington

Postby Robin » Wed Apr 15, 2009 8:13 am

Hi

The function ps3000_get_streaming_last_values requires a pointer to a callback function. The passing of function pointers is not supported by LabVIEW. If you look at our examples, you can see that we have used a wrapper DLL (ps3000wrap.dll) to solve this problem.

If you still get errors, I would check the data types selected in the Call Library Function Nodes against the 3000 User's Guide.

Also, you should select "stdcall" under calling convention.

Hope this helps

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Postby vrpederson » Wed Apr 15, 2009 8:26 pm

Hello Robin,

The 3000 series user guide included in the ps3000sdk_r6_2_2_12.zip file doesn't mention the use of the ps3000wrap.dll. The only place I've been able to find a mention of the ps3000wrap.dll is in the 3425 user guide. Also the examples included in the ps3000sdk don't match what the documentation lists as the included examples.

I'll take a closer look at the included examples.

Thanks for your help.
vrpederson
User
User
 
Posts: 3
Joined: Mon Apr 13, 2009 8:34 pm
Location: Washington


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests