Test and Measurement Forum

PL Freezing... only under recording and using the pc

Forum for discussing PicoLog

PL Freezing... only under recording and using the pc

Postby markv » Tue Apr 07, 2009 11:28 am

Hi there,

I have 2 TC-08's attached to my pc, both serial. This problem happens with one or two attached.

Picolog works 100% if I'm just using it alone on the pc. As soon as I'm recording with picolog and I do something like activate my webcam, or sometimes even switch windows, it freezes.
It doesn't freeze under any circumstances when PL is just monitoring the temps, i.e. not recording. I only have problems when i'm recording temps to a file.

PL will freeze and I have to close and re-open it.

Any suggestions? I haven't tried another pc, since this is the one i have been allocated for my thesis at my university. I have re-installed PL, no change. I'm using the latest version.

Thanks!
markv
User
User
 
Posts: 3
Joined: Tue Apr 07, 2009 11:20 am

Postby ziko » Tue Apr 07, 2009 12:46 pm

Hi try uninstalling the software and installing version 5.16.2 which is available on our software download page. What sampling interval are you choosing by the way and what other settings have you chosen?

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Postby markv » Tue Apr 07, 2009 1:15 pm

I'll give that earlier version a bash. I'm sampling only every 30seconds for my current batch of tests. But in a few days i will be sampling every second.

Does changing the resolution change much?

Thanks
Mark
markv
User
User
 
Posts: 3
Joined: Tue Apr 07, 2009 11:20 am

Postby markv » Tue Apr 07, 2009 2:49 pm

Right, I gave it a go. No joy. It's still freezing. It seemed however, that i could do more in windows than before without it freezing, but it still happened.

I'm running XP SP3. I noticed on the download page that the software says "for xp sp2". Could that be an issue?
markv
User
User
 
Posts: 3
Joined: Tue Apr 07, 2009 11:20 am

Postby Guest » Tue Apr 07, 2009 3:44 pm

Oh, thought I'd point out that another certain time it freezes is when I view the live graph. I don't need to use the graph, but I thought this info might help your diagnosis.

Oh, and please enable the "keep me logged in" checkbox in phpbb. I'm having crazy issues trying stay logged in to post in both IE and Firefox.
Guest
 

Postby Guest » Tue Apr 07, 2009 4:51 pm

Oh, just to make it clear. If I record and don't touch the machine it's fine. I recorded for over 25hours yesterday. It only crashes when I use the PC, or open the graph window.
Guest
 

Postby ziko » Thu Apr 09, 2009 4:13 pm

Thanks for the input, the reason why it would crash when the graph view is open is because if at some point it tried to read and write at the same time this would cause the software to crash. Later versions do not have this problem, I will have to investigate the serial TC-08 with the latest software.

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Re: I am having the same probleum

Postby rider » Sat Dec 05, 2009 5:22 pm

[quote="ziko"]Thanks for the input, the reason why it would crash when the graph view is open is because if at some point it tried to read and write at the same time this would cause the software to crash. Later versions do not have this problem, I will have to investigate the serial TC-08 with the latest software.

Kind regards[/quote]
rider
 

Re: PL Freezing... only under recording and using the pc

Postby rider » Sat Dec 05, 2009 5:25 pm

Ia having the same problem with mt serial TC-08 any fixes yet
rider
 

Re: PL Freezing... only under recording and using the pc

Postby ziko » Mon Dec 07, 2009 9:26 am

What version of the software are you using? Also are you using a USB or standard serial port? If you are using the serial port what voltage are you getting out of pin 4 and 7 on your PC?

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots


Return to PicoLog

Who is online

Users browsing this forum: No registered users and 0 guests