Test and Measurement Forum

ADC11 causes Labview to Crash

Post general discussions on using our drivers to write your own software here

ADC11 causes Labview to Crash

Postby Bonne » Mon Aug 25, 2003 2:53 pm

Hi,
I'm using an ADC11 v1, and writing an interface for it in Labview. As the function adc_get_value isn't fast enough to sample at the rate I need, I used the adc_get_values function (after calling adc_set_interval).

The problem is that it won't always allow me to sample from more than one channel without crashing. I can take 1000 samples from one channel but sometimes when I try to sample more than one it crashes.

I checked that the array size was large enough for the data, and it is (at least samples*channels large).

The crashes occur during the adc_get_values function call.

Can you suggest anything to stop these crashes.
Bonne
 

Postby markspencer » Tue Aug 26, 2003 9:56 am

Hi,

I am going to investigate this and will get back to you as soon as I have some results.

Best regards,
Regards,

Mark Spencer
User avatar
markspencer
Site Admin
Site Admin
 
Posts: 598
Joined: Wed May 07, 2003 9:45 am

Postby markspencer » Tue Aug 26, 2003 3:23 pm

Hi,

I have tried to replicate this, but the Labview program I have works fine. Make sure that you follow the pseudo code in the help file. A common error that can cause this problem is forgetting to call the stop function.

Also down load the latest drivers for the ADC11 these are available from here.

Best regards,
Regards,

Mark Spencer
User avatar
markspencer
Site Admin
Site Admin
 
Posts: 598
Joined: Wed May 07, 2003 9:45 am


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests