Problem for continuous capture mode

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
cberper
User
User
Posts: 3
Joined: Thu Oct 16, 2008 6:58 am

Problem for continuous capture mode

Post by cberper » Fri Jan 09, 2009 12:37 am

Problem for continuous capture mode

Hi, I bought some time picoScope a 2203 attempt to capture in continuous mode (without gaps) a signal of maximum frequency of approximately 4kHz for a total duration of 2 hours and keep it in a single file on my hard disk, but I was totally impossible with your device.

I can see on the screen perfectly with PicoScope 6.0.16.4 but when I try to capture it with me PicoLog Recorder is impossible or even closer to capture the signal as the minimum that I can establish is 1ms. I made a program in C + + to capture the signal but when you call the function with ps2000_run_streaming_ns parameter to false to auto_stop not to stop when you fill the buffer and can capture the memory of the device does not fire the trigger.

How can capture the same speed as with PicoScope Recorder with PicoLog?
Someone can help me or have some code that captures continuously at this frequency?

Robin
Advanced User
Advanced User
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Post by Robin » Fri Jan 09, 2009 11:39 am

Hi

The shortest sampling period that can be used with PicoLog is, as you have found, 1 ms.

I'm not sure why you are having problems triggering with auto_stop=0. We will look in to it.

Robin

Robin
Advanced User
Advanced User
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Post by Robin » Mon Jan 12, 2009 1:20 pm

Hi

Try using the attached DLL. This should solve your triggering problem.

Regards

Robin
Attachments
PS2000.zip
(339.91 KiB) Downloaded 196 times

Post Reply