Test and Measurement Forum

Program crash with Labview?

Post any questions about our parallel port products

Program crash with Labview?

Postby johncht » Wed Jan 07, 2009 9:37 am

Hi.
I am now using Labview 8.0 , DrDAQ and picolog recorder 5.0.
I find that when I open the example in Labview, data can be taken once only. Then there is error when opening picolog recorder , too.
I need to restart my computer in order to use the picolog recorder again.

Also, when I open NI Measurement & Automation program, there is no detection of DrDAQ


Please help.

Regards
John
johncht
Active User
Active User
 
Posts: 9
Joined: Tue Jan 06, 2009 5:12 am

Postby Robin » Wed Jan 07, 2009 10:29 am

Hi John

The LabVIEW example is a simple example intended to get you started. You can modify it to take more than one reading if you wish.

I believe that NI Measurement & Automation Explorer is only for NI hardware.

I'm not sure why you are having problems with PicoLog. Only one program can access the hardware at any one time.

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Postby johncht » Wed Jan 07, 2009 12:14 pm

Dear Robin,
The main probelm is that when I run the example program in Labview, I can only get one result. When I run it again, all readings are zero.
Also, there is error when I open picolog after closing Labview.
I need to restart computer in order to use picolog.

I think there is a crash after I run the example program.

( When I open the picolog, an error : DrDAQ Driver V3.6 pico.sys not found.
After pressing "OK", a second error occurs : DrDAQ LPT1 pico.sys not found)

Hope you can help me.
Thanks for your attention

Regards,
John
johncht
Active User
Active User
 
Posts: 9
Joined: Tue Jan 06, 2009 5:12 am

Postby johncht » Wed Jan 07, 2009 1:06 pm

Here I directly use drdaq_single.vi
I still ahve the same problem...
There is a reading at the begining and then no reading afterwards.

BUT after I try serval times, I can use picolog with no problem without restarting the computer.

But there is still only 1 reading everytime I open the Labview...
Attachments
y.JPG
(98.9 KiB) Downloaded 58 times
johncht
Active User
Active User
 
Posts: 9
Joined: Tue Jan 06, 2009 5:12 am

Postby Robin » Wed Jan 07, 2009 3:09 pm

Hi John

I misunderstood your problem.

The problem of PicoLog crashing can be solved by changing the 'call library function' node to call drdaq_labview_single rather than drdaq_labview_single-2.

We need to investigate why the function is only returning values after its first call. It may be a driver issue or to do with the fact that the DLL function was originally created for a much older version of Labview.

Regards

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Postby johncht » Thu Jan 08, 2009 10:06 am

Hi Robin

Thanks gor your reply.
But I don understand the 1st point.
What should be changed?

Regards,
John
johncht
Active User
Active User
 
Posts: 9
Joined: Tue Jan 06, 2009 5:12 am

Postby Robin » Thu Jan 08, 2009 10:59 am

Hi

In drdaq_single.vi, double click on the central block (this is a Call Library Function Node that is used to access functions in the DLL). Under function name, there is a drop-down menu and drdaq_labview_single-2 will be selected. You should change this to drdaq_labview_single.

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Postby johncht » Thu Jan 08, 2009 1:50 pm

ok i get this
Thanks
johncht
Active User
Active User
 
Posts: 9
Joined: Tue Jan 06, 2009 5:12 am

Postby Robin » Tue Jan 13, 2009 12:14 pm

Hi

This example does not use drdaq_labview_single. It continually updates the display when you run it.

Hope it's useful

Robin
Attachments
DrDaq2.zip
(10.18 KiB) Downloaded 193 times
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Postby johncht » Thu Jan 15, 2009 10:32 am

Robin
Thanks for your great help.

But I find a small problem is that if I want to take sample per second by adding wait function connecting with "1000" constant, then the program works with my expection except that it cant be stopped by clicking the stop button. After this the DrDaq doent work and restart computer is needed for further use.
johncht
Active User
Active User
 
Posts: 9
Joined: Tue Jan 06, 2009 5:12 am

Postby Robin » Thu Jan 15, 2009 12:02 pm

Hi

Try this. Right click on the stop button and select "mechanical action" and change to "latch when pressed" (bottom left).

Hope this helps
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am


Return to Parallel Port Products

Who is online

Users browsing this forum: No registered users and 0 guests