version 6.2 is unable to export spectrum correctly

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
kenjixx
User
User
Posts: 2
Joined: Sat Dec 27, 2008 7:13 am

version 6.2 is unable to export spectrum correctly

Post by kenjixx » Sat Dec 27, 2008 7:56 am

I'm using PicoScope 6.2.0.18.

When I do "Edit -> Copy as Text -> Paste it text editor" in the spectrum view.
First column (of pasted data) is frequency[kHz], but 2nd column is voltage[mV] not [dBu].
And this 2nd column is the same of 2nd column values in the scope view.

This problem also occurs in Files -> Save Current Waveform as -> save as *.txt or *.csv format.

This problem is reproduced after I deleted "~\Local Settings\Application Data\Pico Technology" and reinstalled PicoScope. Latest beta 6.2.1 also causes this problem.

So I cannot export the spectrum. Please Help me.
Attachments
exported_as_txt.zip
exported_spectrum.txt; 2nd column is the same of the scope data. This is not spectrum.
exported_scope.txt; This file has no problem.
(46.12 KiB) Downloaded 227 times

Robin
Advanced User
Advanced User
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Post by Robin » Sat Dec 27, 2008 4:40 pm

Hi kenjixx

I will report this back to our software engineers after our Christmas shut-down.

Robin

Robin
Advanced User
Advanced User
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Post by Robin » Mon Jan 05, 2009 2:28 pm

kenjixx

This bug has now been been fixed and the fix will be included in the next release of PicoScope 6.

Thanks for bringing this to our attention.

Robin

kenjixx
User
User
Posts: 2
Joined: Sat Dec 27, 2008 7:13 am

Post by kenjixx » Tue Jan 06, 2009 6:36 am

Thanks!

But, I would like to use the fixed version as soon as possible.
Because old version 6.1.x cannot open the data saved with version 6.2.

Can I get the fixed beta or the patch?

Robin
Advanced User
Advanced User
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Post by Robin » Tue Jan 13, 2009 2:30 pm

Hi

The latest beta release now includes this fix.

http://labs.picotech.com/

Robin

Chris Stamford-Burrows
User
User
Posts: 6
Joined: Wed Feb 18, 2009 3:03 pm
Location: Asker, Norway

Downloading latest beta release r6.2.1

Post by Chris Stamford-Burrows » Wed Feb 18, 2009 3:15 pm

I am interested to save spectrum data also.
I have just registered at the Forum, and tried to download the BETA software onto a PC with 6.2.0.18 recently installed.

However the insallation does not complete. One Instal windows says the download feture requires 0KB on hard drive.

Is there a problem ?
Aquadyne

Robin
Advanced User
Advanced User
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

Post by Robin » Wed Feb 18, 2009 3:22 pm

Hi Chris

Have you tried uninstalling PS6 first?

Robin

Chris Stamford-Burrows
User
User
Posts: 6
Joined: Wed Feb 18, 2009 3:03 pm
Location: Asker, Norway

Loading BETA version 6.2.1

Post by Chris Stamford-Burrows » Wed Feb 18, 2009 3:42 pm

OK - uninstalling 6.2.0 manually worked.
I'll test the bug-fix tomorrow.

Thanks
Aquadyne

Post Reply