Test and Measurement Forum

USB TC08 get formatted info

Post your LabVIEW discussions here

USB TC08 get formatted info

Postby NeilB » Mon Dec 08, 2008 12:29 pm

I have tried to use the usb_tc08_get_ formatted_ info routine but this always creates an error message 1097 - "An exception occurred within the external code called by a Call Library Function Node. The exception may have corrupted LabVIEW's memory. Save any work to a new location and restart LabVIEW."exception" which LABView cannot handle and so a serious error message occurs."

Is there anything that I can do to make this work without causing this problem?
Attachments
USB TC-08 get unit info query.vi
(44.49 KiB) Downloaded 220 times
NeilB
User
User
 
Posts: 4
Joined: Mon Dec 08, 2008 12:08 pm

Postby Robin » Fri Dec 12, 2008 10:15 am

Hi Neil

Can you save your VI as a Labview 8.2 VI and re-post it?

Thanks

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

USB TC08 get formatted info

Postby NeilB » Fri Dec 12, 2008 1:17 pm

Hello Robin,
Thanks for your reply
Please find VI in 8.2 format attached.
Neil
Attachments
USB TC-08 get unit info query VERSION 8.2.vi
(52.28 KiB) Downloaded 227 times
NeilB
User
User
 
Posts: 4
Joined: Mon Dec 08, 2008 12:08 pm

Postby Robin » Mon Dec 15, 2008 9:26 am

Hi Neil

I have tried your VI and it worked. The usb_tc08_get_ formatted_ info function returned '1' and the correct string without error.

I'm not sure why you are having problems. Is it just this function that is causing errors?

Robin
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

USB TC08 get formatted info

Postby NeilB » Mon Dec 15, 2008 3:48 pm

Yes - I too am able to run it with the output string being obtained and the 1 being returned but then comes a severe error message from the LabVIEW program - that the program has encountered a problem and it needs to close.

I only have problems with this function.
NeilB
User
User
 
Posts: 4
Joined: Mon Dec 08, 2008 12:08 pm

Postby Robin » Tue Dec 16, 2008 1:45 pm

Neil

Try the attached VI and see if you still have the same problem.

Robin
Attachments
get unit info.vi
(11.58 KiB) Downloaded 236 times
Robin
Zen Master
Zen Master
 
Posts: 558
Joined: Fri Sep 19, 2008 10:17 am

GET UNIT INFO FOR TC08

Postby NeilB » Tue Dec 16, 2008 4:28 pm

Thanks alot Robin that seems to work fine.
Neil
NeilB
User
User
 
Posts: 4
Joined: Mon Dec 08, 2008 12:08 pm


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests