Test and Measurement Forum

R6.1.0 unstable with PS3424

Forum for discussing PicoScope version 6 (non-automotive version)

R6.1.0 unstable with PS3424

Postby mpgreen » Thu Sep 04, 2008 10:25 am


Upgraded from 6.0.13 to 6.1.0
PS3424 Scope unplugged during installation.
After install plugged in PS3424
Started 6.1.0 - PS3424 was not detected
File-> Connect Device
Error dialog pops up & 6.1.0 closes itself.
Connected PS3424 to different port, installed driver for new port.
Restart 6.0.1
Same result as above.
Tried uninstall/resinstall of 6.1.0 to no avail.
Installed 6.0.16 works fine.

Can you get your sw team to look at this?

Active User
Active User
Posts: 9
Joined: Fri Mar 23, 2007 10:26 am

Postby PeterF » Fri Sep 05, 2008 12:37 pm

It is possible that the loaded driver has been corrupted and it will not be overwritten by a correct driver until it has been un-installed.
Please try this. Plug in the scope and then go to Windows Device Manager.(Control Panel/System and then look in the Hardware Tab). If there is an "Unknown USB device" there or a "PicoScope 3000 series" with a yellow warning triangle under USB controllers, left click on it once to highlight and then right click to bring up a list from which select "Uninstall". Once that is done, unplug the scope and then plug it back in again. The Windows "New Hardware Found Wizard" will run. Follow the on-screen instructions and, if the wizard asks to connect to Windows Update, select 'No' and allow Windows to automatically detect and configure your scope after which the scope should show up in device manager again but as a "PicoScope 3000 series Oscilloscope". If you get that, your PicoScope6 software should now work.
Zen Master
Zen Master
Posts: 435
Joined: Thu Jun 07, 2007 10:53 am
Location: Cambridgeshire

Postby sjmelnikoff » Tue Sep 09, 2008 8:59 am

Hi. I've had the same issue with a PicoScope 2104, even after uninstalling and re-installing the drivers as suggested.

I've now returned to 5.20.1, which works fine.


Posts: 1
Joined: Tue Sep 09, 2008 8:54 am

Postby gruntman » Tue Sep 09, 2008 11:06 am


There appears to be a corrupt file on your system when the upgrade was installed. You should be able to simply run the install program and instead of uninstalling and reinstalling select the repair option. This will ensure that the installer completely replaces all the files that the program uses. Occasionally when you uninstall/reinstall the programs not all the files are correctly deleted/replaced.

If the repair option does not work then I would recommend a fresh reinstall to ensure that the corrupted file is deleted.

First off with the PicoScope program not running and the PicoScope unit unplugged follow the below steps.

To access the files that I mention below go to the following folders in Windows Explorer and delete them. These folders may be hidden so you may have to go to your folder options under tools and select to show hidden files and folders.

To delete the programs files navigate to and delete the following folder:

C:\Program Files\Pico Technology\PicoScope6

To delete the settings file delete the following folder.

For Vista operating system:
C:\Users\<insert you login user name here>\AppData\Local\Pico Technology

For XP operating system:
C:\Documents and Settings\<insert you login user name here>\Local Settings\Application Data\Pico Technology

Now rerun the 6.1.0 installation program to replace the files. Then reconnect the PicoScope unit and run the PicoScope 6 program. If the program does crash still let us know if it will run without the PicoScope unit attached to the computer and if it does after the PicoScope program is running try connecting the PicoScope unit and going to File and Connect Device and see if the program can successfully open the unit this way.

Let me know how you get along and if following these steps provide you with a solution to your problem.


Richard Boyd
Crag Technologies, Inc
Posts: 109
Joined: Thu Sep 28, 2006 3:50 pm

Postby markl2 » Fri Nov 21, 2008 5:29 am

Same problem with my 3224 scope when back to older version. Tried Richard solution but didn't work.

Posts: 2
Joined: Mon Jun 09, 2008 10:36 pm

Postby ziko » Wed Dec 03, 2008 1:21 pm

If the device cannot be detected in device manager, then there may be something wrong with the unit itself. However there could be other problems like a bad USB cable or a problem with the computer. If all of that has been ruled out then please email at support@picotech.com so we can arrange for the unit to be checked.

Kind regards

Technical Specialist
Zen Master
Zen Master
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests