Test and Measurement Forum

ps2000_open_unit progress indicator?

Post your VB and VBA discussions here

ps2000_open_unit progress indicator?

Postby bmckenney » Fri Jul 25, 2008 5:13 pm

We are driving the PS2205 using a VB6 application. When ps2000_open_unit
is called, a graphic box pops up ("PicoScope(tm)" and a progress bar).

I don't mind the graphic, I guess, but if the open call fails, the graphic
(typically) stays up until my program exits. I haven't found a way to
close it or even move it.

I notice that the picoscope-6 application doesn't have this problem -- it
doesn't seem to display that graphic, and the window it does display goes
away if it can't find any units.

Is there a way I can make this graphic go away when the open completes
(either way), or for that matter make it not appear at all?

Our USB driver is version 1.13.2.0. SDK version is r1_0_0.
bmckenney
Active User
Active User
 
Posts: 11
Joined: Fri Jul 25, 2008 4:21 pm

Workaround

Postby bmckenney » Fri Jul 25, 2008 7:09 pm

I wrote (what amounts to) open_unit using open_unit_async, which gets
around the problem. The graphic still displays, but it goes away when the
open completes.
bmckenney
Active User
Active User
 
Posts: 11
Joined: Fri Jul 25, 2008 4:21 pm

Postby Erik » Wed Oct 15, 2008 8:08 am

I believe this bug has been fixed in the latest driver (ps3000.dll v3.6.3.7).
This version will be available with the next release of PicoScope.
Erik
PICO STAFF
PICO STAFF
 
Posts: 53
Joined: Mon Oct 23, 2006 8:16 am
Location: Cambridgeshire, UK


Return to VB and VBA (Excel, Access)

Who is online

Users browsing this forum: No registered users and 0 guests