PicoScope 7 No longer recognizes 2204a

Having problems ? let us know the details here
Post Reply
JimmyBur
User
User
Posts: 2
Joined: Wed May 15, 2024 3:35 pm

PicoScope 7 No longer recognizes 2204a

Post by JimmyBur »

I have recently gotten a scope for the first time and tried using it the other day with perfect results. Today however, the 2204a is no longer detected on the list of connected devices on the Picoscope 7 program. The Scope appears as unknown in my device manager but running DPinst returns an installation failure message. Multiple reinstallations of the software, reboots, and switching to the early access version came with no results. Any suggestions on how to fix this issue? My laptop OS is Windows 10.

NeilH
PICO STAFF
PICO STAFF
Posts: 286
Joined: Tue Jul 18, 2017 8:28 am

Re: PicoScope 7 No longer recognizes 2204a

Post by NeilH »

Hi

Are you able to try a different USB cable, whether its one of the blue Pico ones or a 3rd party one?
Are you able to try uninstalling and reinstalling PicoScope 7?
Neil
Technical Support Engineer

JimmyBur
User
User
Posts: 2
Joined: Wed May 15, 2024 3:35 pm

Re: PicoScope 7 No longer recognizes 2204a

Post by JimmyBur »

Hi Neil,

Unfortunately yes I have tried a different USB cable as well as reinstalling PicoScope 7 to no success. I have also tried the early access version of PicoScope 7 with the same results.

Willem43
Newbie
Posts: 1
Joined: Wed Jul 21, 2021 11:56 am

Re: PicoScope 7 No longer recognizes 2204a

Post by Willem43 »

A bit of a shot in the dark.

Are you using the same USB port as before? I know at least one of my USB 3.0 ports, which does work otherwise, does not see my 2207B MSO. I cannot remember if it did at some stage in the past (I do however have vague memories that it actually did - no idea what changed).

Post Reply