Pico state

Post your Python discussions here.
Post Reply
woyokaa
Newbie
Posts: 0
Joined: Fri Apr 12, 2024 8:07 am

Pico state

Post by woyokaa »

HI

I would like to ask, after running the oscilloscope once in streaming mode, how can I reset it to its original state for the second run? Even after closing and restarting the oscilloscope and reconfiguring it, the status still shows 'getStreamingLatestValues': 407. However, when I run streaming mode for the second time, it doesn't work correctly.

I use four Picoscope 6824E. The environment is win10.

ps.ps6000aRunStreaming: {'setChannelA': 0, 'setDataBuffersA': 0, 'setChannelB': 0, 'setDataBuffersB': 0, 'setChannelC': 0, 'setDataBuffersC': 0, 'setChannelD': 0, 'setDataBuffersD': 0, 'setChannelE': 0, 'setDataBuffersE': 0, 'setChannelF': 0, 'setDataBuffersF': 0, 'setChannelG': 0, 'setDataBuffersG': 0, 'setChannelH': 0, 'setDataBuffersH': 0, 'getAdcLimits': 0, 'setTriggerChannelConditions': 0, 'setTriggerChannelDirections': 0, 'setTriggerChannelProperties': 0, 'runStreaming': 0, 'getStreamingLatestValues': 407, 'setDataBufferA': 0, 'setDataBufferB': 0, 'setDataBufferC': 0, 'setDataBufferD': 0}

woyoka
Newbie
Posts: 0
Joined: Wed Apr 10, 2024 12:41 am

Re: Pico state

Post by woyoka »

Additional information:
I'd like to inquire about how to clear the buffer area and whether there is a function available in PS6000A for this purpose? In this instance, I used clear = enums.PICO_ACTION["PICO_CLEAR_ALL"] within the ps.ps6000aSetDataBuffer function, but it doesn't seem to work.

Post Reply