TC-08 data discrepancy

Post any questions you may have about our current range of USB data loggers
Post Reply
Posts: 0
Joined: Thu Sep 03, 2020 4:14 pm

TC-08 data discrepancy

Post by do0mn0ob »

Hi, I'm having problems with data returned from a TC-08 logger to several laptops, in which the voltage displayed in Picolog is between 2.5 and 3 times lower than it should be. This also applies when using the TC-08 terminal board - voltages are less than expected, even with the 101x reduction from a ±5V signal.

The voltage returned from the transducer is correct, as is the output from the terminal board. I have tried multiple loggers and multiple USB cables, all with no effect. But, one thing that does appear to make a difference is the operating system, where windows 11 produces the correct result in Picolog and Windows 10 doesn't. I'm using the latest Picolog 6.2.8 but v5 does the same thing.

I'm not using scaling with the terminal board but the terminal board ±5V setting is defined as the input. I should say that while the output is wrong, it is repeatably wrong so we can work with it.

I also tried uninstalling the TC-08 device in device manager but that did nothing.



Posts: 1124
Joined: Mon Aug 11, 2014 11:14 am

Re: TC-08 data discrepancy

Post by Gerry »

Hi Phil,

Sorry for the late response. If you haven't managed to solve the problem then we would suggest the following:

It would be extremely unusual for the actual operating system to be causing the difference in levels (the only thing I could think of would be some kind of driver handling bug, but we would have seen more instances of this problem, if that was the case).

Presumably you're comparing 2 different computers running Windows 10 and Windows 11. So, It's more likely to be something like a driver error, where you have the wrong driver running on the Windows 10 machine. Uninstalling the driver may not necessarily work, as the computer can revert to a previously installed driver. You can check if the driver uninstalled, completely, by rebooting the Machine and then looking in the Device Manager again.

However what I would suggest that you try next is to completely remove all drivers, along with the software and then re-install a copy of the latest version of the software. The steps to do this would be as follows:
1/ Uninstall PicoLog on the computer, using 'Add or Remove Programmes'.
2/ With your TC-08 connected, uninstall the Driver shown for the Device by (a) going to the Device Manager and right clicking on the displayed drivers to uninstall, then (b) while still in the Device Manager, click on the ‘Show Hidden Devices’ option in the ‘View' Menu, and then delete all the displayed drivers. then (c) again, while in the Device Manager, click on 'Universal Serial Bus Controllers’ and delete any drivers with yellow exclamation marks.
3/ Delete your download of the PicoLog 6 version that you were using, then save all changes to applications documents and data files, etc, that you don’t want to lose, and force a shutdown of the Computer using the On/Shutdown button.
4/ Reboot your computer, then Download and Install the latest PicoLog 6 version from our downloads page.
5/ Connect your TC-08 and Start your PicoLog 6 software to see if it fixes the scaling.

In case there isn't a Driver issue, could you send us Photos of the complete connection setups, and equipment for both computers (as I assume that your not reinstalling the OS's on the same machine), and give us the System Info for both machines.


Technical Specialist

Post Reply