PicoSDK on Red Hat

Post your Linux discussions here
Post Reply
niyohn
Newbie
Posts: 0
Joined: Wed Mar 09, 2022 4:28 pm

PicoSDK on Red Hat

Post by niyohn »

Hi, Im trying to connect to ADC24 and TC-08 on Red Hat 7.
The Appimage for PicoLog doesnt seem to work on Red Hat 7 (works on 8) so i need to build my own software.
Where can i get the picohrdl driver? the download page only lists Ubuntu and OpenSUSE via repo. Is there a webpage where you can directly download the SDK?

AndrewA
PICO STAFF
PICO STAFF
Posts: 328
Joined: Tue Oct 21, 2014 3:07 pm

Re: PicoSDK on Red Hat

Post by AndrewA »

Hi,
No we don't offer SDK files for linux, only via repos and PicoLog 6.
https://labs.picotech.com/debian/ (.deb files)
https://labs.picotech.com/rpm/ (.rpm files)
You can also extract the .so files from PicoLog 6 appimage but I don't know what libraries these depend on.
See - viewtopic.php?p=146876#p146876
Regards Andrew
Technical Specialist

alongv
Newbie
Posts: 0
Joined: Tue Apr 05, 2022 9:07 am

Re: PicoSDK on Red Hat

Post by alongv »

I can share that I have successfully run picoscope from the OpenSuse repository on fedora 36.

I installed it using the following repo file in /etc/yum.repos.d named picoscope.repo:

[picoscope]
name=Picoscope
baseurl=https://labs.picotech.com/rc/picoscope7/rpm/
gpgcheck=0

(the gpgcheck=0 is an ugly touch, I'm sure it is possible to import the gpg key correctly).

HTH,
Alon

ja@jaa.org.uk
Newbie
Posts: 0
Joined: Mon Jan 28, 2019 10:30 am

Re: PicoSDK on Red Hat

Post by ja@jaa.org.uk »

Hi Alon (or Andrew)
I have tried to replicate your successful installation of picoscope7
on F36 but get the following problems - have you any suggestions?
[root@naxos:~]$ dnf install picoscope

Local ja Fedora 36 x86_64 Updates 3.0 MB/s | 3.0 kB 00:00
Error:
Problem: conflicting requests
- nothing provides mono(DocumentFormat.OpenXml) = 2.7.2.0 needed by picoscope-7.0.98-1r11193.x86_64
- nothing provides mono(ExcelNumberFormat) = 1.0.10.0 needed by picoscope-7.0.98-1r11193.x86_64
- nothing provides mono(System.Runtime.CompilerServices.Unsafe) = 4.0.4.1 needed by picoscope-7.0.98-1r11193.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Many thanks

John

Post Reply