Running AppImages on Fedora 35

Discussion forum for the Picoscope 6 Linux software
Post Reply
benpac
Newbie
Posts: 0
Joined: Fri Nov 19, 2021 3:12 pm

Running AppImages on Fedora 35

Post by benpac »

I am having a 5444B and recently upgraded Fedora 34 -> 35.
For the upgrade I had to uninstall packages related to pico. PicoScope 6 worked with F34

I have started picolog-6.1.18-x86_64.AppImage as well as a freshly downloaded picolog-6.2.1-x86_64.AppImage.
In both cases I see a blank program form with caption PicoLog which disappears after less than a second.

When trying to install libpicoipp

Code: Select all

sudo dnf install libpicoipp
Error: 
 Problem: conflicting requests
  - nothing provides libiomp5.so()(64bit) needed by libpicoipp-1.3.0-4r121.x86_64
  - nothing provides libiomp5.so(VERSION)(64bit) needed by libpicoipp-1.3.0-4r121.x86_64
Is it a specific Fedora 35 problem?

Will there be a PicoScope AppImage too?
Last edited by benpac on Tue Nov 23, 2021 2:19 pm, edited 1 time in total.

A.P.
Newbie
Posts: 0
Joined: Mon Oct 25, 2021 9:51 am

Re: Running AppImages on Fedora 35

Post by A.P. »

I'm not sure if this will help but I had a similar error message concerning libpicoipp-1.3.0-4r121.x86_64 regarding libiomp5.so, when I was installing picoscope on F35. I worked round it by manually installing libpicoipp-1.3.0-4r29.x86_64.rpm an older one. The ones after this are missing libiomp5.so.
Maybe this will help you.

benpac
Newbie
Posts: 0
Joined: Fri Nov 19, 2021 3:12 pm

Re: Running AppImages on Fedora 35

Post by benpac »

I gave picotech (6.14.54-4r6108) in the repository a new chance today, but failed again, libiomp5.so being missing.
I have followed the recent comment of A.P. (thanks !) trying to install an older version:

sudo dnf install libpicoipp-1.3.0-4r29.x86_64.rpm
Can not load RPM file: libpicoipp-1.3.0-4r29.x86_64.rpm.

sudo dnf install libpicoipp-1.3.0-4r29.x86_64
worked neither.

By the way:
Although the 5444B not being a logger, I have run picolog-6.2.2-x86_64.AppImage and this works with the Scope :D , the earlier versions picolog-6.2.1-x86_64.AppImage and picolog-6.1.18-x86_64.AppImage did not.
Basically it works with an Appimage under F35, hope that there will be an Picotech Appimage too soon !

Post Reply